CWE
362
Advisory Published
Updated

CVE-2022-23042: Race Condition

First published: Thu Mar 10 2022(Updated: )

Linux PV device frontends vulnerable to attacks by backends T[his CNA information record relates to multiple CVEs; the text explains which aspects/vulnerabilities correspond to which CVE.] Several Linux PV device frontends are using the grant table interfaces for removing access rights of the backends in ways being subject to race conditions, resulting in potential data leaks, data corruption by malicious backends, and denial of service triggered by malicious backends: blkfront, netfront, scsifront and the gntalloc driver are testing whether a grant reference is still in use. If this is not the case, they assume that a following removal of the granted access will always succeed, which is not true in case the backend has mapped the granted page between those two operations. As a result the backend can keep access to the memory page of the guest no matter how the page will be used after the frontend I/O has finished. The xenbus driver has a similar problem, as it doesn't check the success of removing the granted access of a shared ring buffer. blkfront: CVE-2022-23036 netfront: CVE-2022-23037 scsifront: CVE-2022-23038 gntalloc: CVE-2022-23039 xenbus: CVE-2022-23040 blkfront, netfront, scsifront, usbfront, dmabuf, xenbus, 9p, kbdfront, and pvcalls are using a functionality to delay freeing a grant reference until it is no longer in use, but the freeing of the related data page is not synchronized with dropping the granted access. As a result the backend can keep access to the memory page even after it has been freed and then re-used for a different purpose. CVE-2022-23041 netfront will fail a BUG_ON() assertion if it fails to revoke access in the rx path. This will result in a Denial of Service (DoS) situation of the guest which can be triggered by the backend. CVE-2022-23042

Credit: security@xen.org security@xen.org

Affected SoftwareAffected VersionHow to fix
Xen Xen
Debian Debian Linux=9.0
ubuntu/linux<4.15.0-177.186
4.15.0-177.186
ubuntu/linux<5.4.0-117.132
5.4.0-117.132
ubuntu/linux<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws<4.15.0-1128.137
4.15.0-1128.137
ubuntu/linux-aws<5.4.0-1078.84
5.4.0-1078.84
ubuntu/linux-aws<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.0<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.11<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.3<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.4<5.4.0-1078.84~18.04.1
5.4.0-1078.84~18.04.1
ubuntu/linux-aws-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-5.8<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-fips<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-hwe<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-aws-hwe<4.15.0-1128.137~16.04.1
4.15.0-1128.137~16.04.1
ubuntu/linux-azure<5.4.0-1083.87
5.4.0-1083.87
ubuntu/linux-azure<4.15.0-1138.151~14.04.1
4.15.0-1138.151~14.04.1
ubuntu/linux-azure<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure<4.15.0-1138.151~16.04.1
4.15.0-1138.151~16.04.1
ubuntu/linux-azure-4.15<4.15.0-1138.151
4.15.0-1138.151
ubuntu/linux-azure-4.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-5.11<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-5.3<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-5.4<5.4.0-1083.87~18.04.1
5.4.0-1083.87~18.04.1
ubuntu/linux-azure-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-edge<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-fde<5.4.0-1083.87
5.4.0-1083.87
ubuntu/linux-azure-fde<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-fde-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-azure-fips<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-bluefield<5.4.0-1040.44
5.4.0-1040.44
ubuntu/linux-bluefield<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-dell300x<4.15.0-1042.47
4.15.0-1042.47
ubuntu/linux-dell300x<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-fips<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp<5.4.0-1078.84
5.4.0-1078.84
ubuntu/linux-gcp<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp<4.15.0-1122.136~16.04.1
4.15.0-1122.136~16.04.1
ubuntu/linux-gcp-4.15<4.15.0-1122.136
4.15.0-1122.136
ubuntu/linux-gcp-4.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-5.11<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-5.3<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-5.4<5.4.0-1078.84~18.04.1
5.4.0-1078.84~18.04.1
ubuntu/linux-gcp-5.8<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gcp-fips<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gke<5.4.0-1074.79
5.4.0-1074.79
ubuntu/linux-gke<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gke-4.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gke-5.0<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gke-5.3<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gke-5.4<5.4.0-1074.79~18.04.1
5.4.0-1074.79~18.04.1
ubuntu/linux-gke-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gkeop<5.4.0-1046.48
5.4.0-1046.48
ubuntu/linux-gkeop<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gkeop-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-gkeop-5.4<5.4.0-1046.48~18.04.1
5.4.0-1046.48~18.04.1
ubuntu/linux-gkeop-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe<4.15.0-177.186~16.04.1
4.15.0-177.186~16.04.1
ubuntu/linux-hwe-5.11<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe-5.4<5.4.0-117.132~18.04.1
5.4.0-117.132~18.04.1
ubuntu/linux-hwe-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe-5.8<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-hwe-edge<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-ibm<5.4.0-1026.29
5.4.0-1026.29
ubuntu/linux-ibm<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-ibm-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-ibm-5.4<5.4.0-1028.32~18.04.1
5.4.0-1028.32~18.04.1
ubuntu/linux-ibm-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-intel<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-intel-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-intel-iotg<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-intel-iotg-5.15<5.15.0-1008.11~20.04.1
5.15.0-1008.11~20.04.1
ubuntu/linux-intel-iotg-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-iot<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-kvm<4.15.0-1114.117
4.15.0-1114.117
ubuntu/linux-kvm<5.4.0-1068.72
5.4.0-1068.72
ubuntu/linux-kvm<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-laptop<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-lowlatency<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-lowlatency-hwe-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-lowlatency-hwe-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-lts-xenial<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-nvidia<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-nvidia-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-5.10<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-5.17<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-5.6<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-6.8<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oem-osp1<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle<4.15.0-1093.102
4.15.0-1093.102
ubuntu/linux-oracle<5.4.0-1076.83
5.4.0-1076.83
ubuntu/linux-oracle<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle<4.15.0-1093.102~16.04.1
4.15.0-1093.102~16.04.1
ubuntu/linux-oracle-5.0<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle-5.11<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle-5.13<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle-5.3<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-oracle-5.4<5.4.0-1076.83~18.04.1
5.4.0-1076.83~18.04.1
ubuntu/linux-oracle-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-raspi<5.4.0-1065.75
5.4.0-1065.75
ubuntu/linux-raspi<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-raspi-5.4<5.4.0-1065.75~18.04.1
5.4.0-1065.75~18.04.1
ubuntu/linux-raspi-5.4<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-raspi2<4.15.0-1109.116
4.15.0-1109.116
ubuntu/linux-raspi2<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-raspi2-5.3<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-riscv<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-riscv-5.11<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-riscv-5.15<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-riscv-5.8<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-riscv-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-snapdragon<4.15.0-1127.136
4.15.0-1127.136
ubuntu/linux-snapdragon<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-starfive<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-starfive-6.5<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
ubuntu/linux-xilinx-zynqmp<5.17~<5.4.184<5.15.28
5.17~
5.4.184
5.15.28
debian/linux
5.10.218-1
6.1.94-1
6.1.90-1
6.9.8-1
6.9.9-1

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Parent vulnerabilities

(Appears in the following advisories)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203