CVE-2022-23096: Critical severity Intel Connman vulnerability

Published Jan 28, 2022
·
Updated

An issue was discovered in the DNS proxy in Connman through 1.40. The TCP server reply implementation lacks a check for the presence of sufficient Header Data, leading to an out-of-bounds read.

Affected Software

21 affected componentsFixes available
debian/connman<=1.36-2.3, <=1.36-2.1~deb10u1, <=1.36-2.1~deb10u2, <=1.36-2.2
1.36-2.41.36-2.2+deb11u1
ubuntu/connman<1.35-6ubuntu0.1~
1.35-6ubuntu0.1~
ubuntu/connman<1.21-1.2+
1.21-1.2+
ubuntu/connman<1.36-2.3ubuntu0.1
1.36-2.3ubuntu0.1
ubuntu/connman<1.36-2ubuntu0.1
1.36-2ubuntu0.1
Intel Connman<=1.40
Debian Debian Linux=9.0
Debian Debian Linux=11.0
debian/connman<1.36-2.4
1.36-2.4
debian/connman<1.36-2.4
1.36-2.4
debian/connman<1.36-2.4
1.36-2.4
debian/connman
1.41-31.44-32.0-2
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.4Fixed in 1.36-2.2+deb11u1
  2. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.35-6ubuntu0.1~
  3. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.21-1.2+
  4. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.3ubuntu0.1
  5. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2ubuntu0.1
  6. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.41-3Fixed in 1.44-3Fixed in 2.0-2
  7. Upgrade

    Upgrade alpine/connman to a version that resolves this vulnerability.

    Fixed in 1.41-r0
  8. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.4

Event History

Jan 28, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID for this issue?

The vulnerability ID for this issue is CVE-2022-23096.

2

What software is affected by this vulnerability?

Connman versions 1.21-1.2+ through 1.40 are affected by this vulnerability.

3

What is the severity of CVE-2022-23096?

The severity of CVE-2022-23096 is not mentioned in the provided information.

4

How can I mitigate the vulnerability in Connman?

To mitigate the vulnerability in Connman, update to version 1.41-3 or the latest available version.

5

Where can I find more information about CVE-2022-23096?

You can find more information about CVE-2022-23096 in the provided references: [Link1], [Link2], [Link3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203