CVE-2022-23098: High severity Intel Connman vulnerability

Published Jan 28, 2022
·
Updated

An issue was discovered in the DNS proxy in Connman through 1.40. The TCP server reply implementation has an infinite loop if no data is received.

Affected Software

20 affected componentsFixes available
ubuntu/connman<1.21-1.2+
1.21-1.2+
ubuntu/connman<1.35-6ubuntu0.1~
1.35-6ubuntu0.1~
ubuntu/connman<1.36-2ubuntu0.1
1.36-2ubuntu0.1
ubuntu/connman<1.36-2.3ubuntu0.1
1.36-2.3ubuntu0.1
Intel Connman<=1.40
Debian Debian Linux=9.0
Debian Debian Linux=11.0
debian/connman<1.36-2.4
1.36-2.4
debian/connman<1.36-2.4
1.36-2.4
debian/connman<1.36-2.4
1.36-2.4
debian/connman
1.41-31.44-32.0-2
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0
alpine/connman<1.41-r0
1.41-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.21-1.2+
  2. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.35-6ubuntu0.1~
  3. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2ubuntu0.1
  4. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.3ubuntu0.1
  5. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.41-3Fixed in 1.44-3Fixed in 2.0-2
  6. Upgrade

    Upgrade alpine/connman to a version that resolves this vulnerability.

    Fixed in 1.41-r0
  7. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.4

Event History

Jan 28, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID for this issue in Connman?

The vulnerability ID for this issue in Connman is CVE-2022-23098.

2

What is the severity of CVE-2022-23098?

The severity of CVE-2022-23098 is high with a CVSS score of 7.5.

3

What is the affected software in this vulnerability?

The affected software in this vulnerability is Connman.

4

How can I fix CVE-2022-23098?

To fix CVE-2022-23098, you should update Connman to version 1.41-3 or apply the recommended patches provided by the respective software vendors.

5

Where can I find more information about CVE-2022-23098?

You can find more information about CVE-2022-23098 at the following references: [link1], [link2], [link3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203