CVE-2022-23494: Cross-site scripting vulnerability in TinyMCE alerts
Impact A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user.
Patches This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements.
Fix To avoid this vulnerability: - Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x. - Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x.
Workaround To reduce the impact of this vulnerability: - Ensure the the imagesuploadhandler returns a valid value as per the imagesuploadhandler documentation.
References - https://www.tiny.cloud/docs/release-notes/release-notes5107/#securityfixes - https://www.tiny.cloud/docs/tinymce/6/6.3-release-notes/#security-fixes
For more information If you have any questions or comments about this advisory: Email us at infosec@tiny.cloud Open an issue in the TinyMCE repo
Other sources
Cross-site scripting vulnerability in TinyMCE alerts
— Packagist
tinymce is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Users are advised to upgrade to either 5.10.7 or 6.3.1. Users unable to upgrade may ensure the the imagesuploadhandler returns a valid value as per the imagesuploadhandler documentation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/tinymce/tinymceto a version that resolves this vulnerability.Fixed in 5.10.7 - Upgrade
Upgrade
composer/tinymce/tinymceto a version that resolves this vulnerability.Fixed in 6.3.1 - Upgrade
Upgrade
nuget/TinyMCEto a version that resolves this vulnerability.Fixed in 5.10.7 - Upgrade
Upgrade
npm/tinymceto a version that resolves this vulnerability.Fixed in 5.10.7 - Upgrade
Upgrade
nuget/TinyMCEto a version that resolves this vulnerability.Fixed in 6.3.1 - Upgrade
Upgrade
npm/tinymceto a version that resolves this vulnerability.Fixed in 6.3.1 - Upgrade
Upgrade
TinyMCE 5.xto a version that resolves this vulnerability.Fixed in 5.10.7 - Upgrade
Upgrade
TinyMCE 6.xto a version that resolves this vulnerability.Fixed in 6.3.1 - Configuration
Ensure the images_upload_handler returns a valid value as specified in the images_upload_handler documentation.
TinyMCE images_upload_handler = valid value as per the images_upload_handler documentation
Event History
Frequently Asked Questions
What is CVE-2022-23494?
CVE-2022-23494 is a cross-site scripting (XSS) vulnerability discovered in the alert and confirm dialogs of the TinyMCE rich text editor.
How does CVE-2022-23494 occur?
CVE-2022-23494 can occur when the alert or confirm dialogs in plugins, such as the image plugin, are provided with malicious HTML content.
What is the severity of CVE-2022-23494?
CVE-2022-23494 has a severity score of 6.1, which is considered medium.
Which versions of TinyMCE are affected by CVE-2022-23494?
Versions up to and exclusive of 5.10.7 and versions from 6.0.0 to 6.3.1 of TinyMCE are affected by CVE-2022-23494.
How can I fix CVE-2022-23494?
To fix CVE-2022-23494, it is recommended to update to a version of TinyMCE that is not affected by the vulnerability.