CVE-2022-23807: Improper Authentication in phpmyadmin
An issue was discovered in phpMyAdmin 4.9 before 4.9.8 and 5.1 before 5.1.2. A valid user who is already authenticated to phpMyAdmin can manipulate their account to bypass two-factor authentication for future login instances.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 5.1.2 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.9.8 - Upgrade
Upgrade
debian/phpmyadminto a version that resolves this vulnerability.Fixed in 4:5.2.1+dfsg-1+deb12u1Fixed in 4:5.2.2-really+dfsg-1+deb13u1Fixed in 4:5.2.4~dev~git20260809.e0909b211b+dfsg-1 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 5.1.2-r0 - Upgrade
Upgrade
debian/phpmyadminto a version that resolves this vulnerability.Fixed in 4:5.1.3+dfsg1-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2022-23807.
What is the severity of CVE-2022-23807?
The severity of CVE-2022-23807 is medium with a CVSS score of 4.3.
What is the affected software for CVE-2022-23807?
The affected software for CVE-2022-23807 is phpMyAdmin versions 4.9 before 4.9.8 and 5.1 before 5.1.2.
How does CVE-2022-23807 impact users?
CVE-2022-23807 allows a valid user who is already authenticated to phpMyAdmin to bypass two-factor authentication for future login instances.
How can I fix CVE-2022-23807?
To fix CVE-2022-23807, it is recommended to upgrade to phpMyAdmin version 4.9.8 or 5.1.2.