CVE-2022-23808: Cross-site Scripting in phpmyadmin
An issue was discovered in phpMyAdmin 5.1 before 5.1.2. An attacker can inject malicious code into aspects of the setup script, which can allow XSS or HTML injection.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 5.1.2 - Upgrade
Upgrade
debian/phpmyadminto a version that resolves this vulnerability.Fixed in 4:5.2.1+dfsg-1+deb12u1Fixed in 4:5.2.2-really+dfsg-1+deb13u1Fixed in 4:5.2.4~dev~git20260809.e0909b211b+dfsg-1 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 5.1.2-r0 - Upgrade
Upgrade
debian/phpmyadminto a version that resolves this vulnerability.Fixed in 4:5.1.3+dfsg1-1
Event History
Frequently Asked Questions
What is the severity of CVE-2022-23808?
The severity of CVE-2022-23808 is medium with a CVSS score of 6.1.
What is the affected software for CVE-2022-23808?
The affected software for CVE-2022-23808 is phpMyAdmin 5.1 before 5.1.2.
What can an attacker do with CVE-2022-23808?
An attacker can inject malicious code into aspects of the setup script, allowing XSS or HTML injection.
How can I fix CVE-2022-23808?
To fix CVE-2022-23808, upgrade phpMyAdmin to version 5.1.2 or later.
Where can I find more information about CVE-2022-23808?
You can find more information about CVE-2022-23808 on the phpMyAdmin security page [here](https://www.phpmyadmin.net/security/PMASA-2022-2/).