CVE-2022-24872: Improper Access Control in Shopware

Published Apr 20, 2022
·
Updated

Improper Access Control in Shopware

Other sources

Shopware 6 is an open commerce platform based on Symfony Framework and Vue and supported by a worldwide community and more than 1.500 community extensions. Permissions set to sales channel context by admin-api are still useable within normal user session. We recommend updating to the current version 6.4.10.1. You can get the update to 6.4.10.1 regularly via the Auto-Updater or directly via the download overview. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

— GitHub

Shopware is an open commerce platform based on Symfony Framework and Vue. Permissions set to sales channel context by admin-api are still usable within normal user session. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Affected Software

5 affected componentsFixes available
Shopware Shopware<6.4.10.1
composer/shopware/core<=6.3.4.0
composer/shopware/platform<=6.3.4.0
composer/shopware/core<=6.3.4.0
6.4.10.1
composer/shopware/platform<=6.3.4.0
6.4.10.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/shopware/core to a version that resolves this vulnerability.

    Fixed in 6.4.10.1
  2. Upgrade

    Upgrade composer/shopware/platform to a version that resolves this vulnerability.

    Fixed in 6.4.10.1
  3. Upgrade

    Upgrade Shopware to a version that resolves this vulnerability.

    Fixed in 6.4.10.1

Event History

Apr 20, 2022
CVE Published
via MITRE·07:15 PM
Data Sourced
via MITRE·07:15 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Apr 22, 2022
Advisory Published
via GitHub·09:04 PM
Data Sourced
via GitHub·09:04 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:04 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2022-24872?

CVE-2022-24872 is a vulnerability in Shopware that allows users to exploit permissions set to sales channel context by the admin-api within a normal user session.

2

How severe is CVE-2022-24872?

CVE-2022-24872 has a severity score of 8.1, which is considered high.

3

How can I fix CVE-2022-24872?

To fix CVE-2022-24872, users are advised to update to the current version 6.4.10.1 of Shopware.

4

Where can I find more information about CVE-2022-24872?

More information about CVE-2022-24872 can be found in the official Shopware security updates documentation and the GitHub advisory.

5

What is the CWE for CVE-2022-24872?

The CWE for CVE-2022-24872 is CWE-732.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203