CVE-2022-25271: Improper input validation in Drupal core

Published Feb 16, 2022
·
Updated

Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.

Other sources

Improper input validation in Drupal core

— Packagist

Affected Software

17 affected componentsFixes available
Drupal Drupal>=7.0.0<7.88
Drupal Drupal>=9.2.0<9.2.13
Drupal Drupal>=9.3.0<9.3.6
Fedoraproject Fedora=35
Fedoraproject Fedora=36
composer/drupal/core>=7.0.0, <7.88
7.88
composer/drupal/core>=8.0.0, <9.2.13
9.2.13
composer/drupal/core>=9.3.0, <9.3.6
9.3.6
composer/drupal/core>=7.0.0<7.88
7.88
composer/drupal/core>=8.0.0<9.2.13
9.2.13
composer/drupal/core>=9.3.0<9.3.6
9.3.6
alpine/drupal7<7.89-r0
7.89-r0
alpine/drupal7<7.89-r0
7.89-r0
alpine/drupal7<7.89-r0
7.89-r0
alpine/drupal7<7.89-r0
7.89-r0
alpine/drupal7<7.89-r0
7.89-r0
alpine/drupal7<7.89-r0
7.89-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 7.88
  2. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 9.2.13
  3. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 9.3.6

Event History

Feb 16, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via NVD·11:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·11:15 PM
DescriptionSeverityAffected Software
Feb 18, 2022
Advisory Published
via GitHub·12:00 AM
Data Sourced
via GitHub·12:00 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:00 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2022-25271?

CVE-2022-25271 is a vulnerability in Drupal core's form API that allows certain contributed or custom modules' forms to be vulnerable to improper input validation.

2

How severe is CVE-2022-25271?

CVE-2022-25271 has a severity score of 7.5, which is considered high.

3

Which software versions are affected by CVE-2022-25271?

CVE-2022-25271 affects Drupal versions 7.0.0 to 7.88, 9.2.0 to 9.2.13, and 9.3.0 to 9.3.6.

4

How can an attacker exploit CVE-2022-25271?

An attacker could exploit CVE-2022-25271 by injecting disallowed values or overwriting data in certain vulnerable forms.

5

Are there any references for CVE-2022-25271?

Yes, you can find references for CVE-2022-25271 at the following links: [Link 1](https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3/), [Link 2](https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4/), [Link 3](https://www.drupal.org/sa-core-2022-003).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203