CVE-2022-25278: Drupal core - Moderately critical - Access Bypass - SA-CORE-2022-013

Published Jul 20, 2022
·
Updated

Drupal core - Moderately critical - Access Bypass - SA-CORE-2022-013

Other sources

Drupal core form API evaluates form element access incorrectly. This can lead to a user being able to alter data they should not have access to.

Under certain circumstances, the Drupal core form API evaluates form element access incorrectly. This may lead to a user being able to alter data they should not have access to. No forms provided by Drupal core are known to be vulnerable. However, forms added through contributed or custom modules or themes may be affected.

Affected Software

7 affected componentsFixes available
composer/drupal/core>=8.0.0, <9.3.19, >=9.4.0, <9.4.3
composer/drupal/core>=9.4.0<9.4.3
9.4.3
composer/drupal/core>=8.0.0<9.3.19
9.3.19
Drupal Drupal>=8.0.0<9.3.19
Drupal Drupal>=9.4.0<9.4.3
composer/drupal/core>=8.0.0, <9.3.19
9.3.19
composer/drupal/core>=9.4.0, <9.4.3
9.4.3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 9.4.3
  2. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 9.3.19

Event History

Jul 20, 2022
Advisory Published
10:11 AM
Data Sourced
via Packagist·10:11 AM
DescriptionSeverityAffected Software
Apr 26, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness

Frequently Asked Questions

1

What is CVE-2022-25278?

CVE-2022-25278 is a vulnerability in Drupal core that allows a user to alter data they should not have access to.

2

What is the severity of CVE-2022-25278?

The severity of CVE-2022-25278 is classified as moderately critical.

3

Which versions of Drupal core are affected by CVE-2022-25278?

Drupal core versions 8.0.0 to 9.3.19 and 9.4.0 to 9.4.3 are affected by CVE-2022-25278.

4

Are forms provided by Drupal core vulnerable to CVE-2022-25278?

No, forms provided by Drupal core are not known to be vulnerable to CVE-2022-25278.

5

Where can I find more information about CVE-2022-25278?

You can find more information about CVE-2022-25278 on the Drupal website at https://www.drupal.org/sa-core-2022-013.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203