CVE-2022-25769: Improper regex in htaccess file

Published Mar 1, 2022
·
Updated

Impact the default .htaccess file has some restrictions in the access to PHP files to only allow specific PHP files to be executed in the root of the application.

This logic isn't correct, as the regex in the second FilesMatch only checks the filename, not the full path.

Patches Please upgrade to 3.3.5 or 4.2.0

Workarounds No

References

- Release post: https://www.mautic.org/blog/community/mautic-4-2-one-small-step-mautic - Internally tracked under MST-32

For more information If you have any questions or comments about this advisory: Email us at security@mautic.org

Other sources

ImpactThe default .htaccess file has some restrictions in the access to PHP files to only allow specific PHP files to be executed in the root of the application.

This logic isn't correct, as the regex in the second FilesMatch only checks the filename, not the full path.

— MITRE

Affected Software

6 affected componentsFixes available
Acquia Mautic<3.3.5
Acquia Mautic>=4.0.0<4.2.0
composer/mautic/core>=4.0.0, <4.2.0
4.2.0
composer/mautic/core<3.3.5
3.3.5
composer/mautic/core>=4.0.0<4.2.0
4.2.0
composer/mautic/core<3.3.5
3.3.5

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/mautic/core to a version that resolves this vulnerability.

    Fixed in 4.2.0
  2. Upgrade

    Upgrade composer/mautic/core to a version that resolves this vulnerability.

    Fixed in 3.3.5
  3. Upgrade

    Upgrade Mautic to a version that resolves this vulnerability.

    Fixed in 3.3.5

Event History

Mar 1, 2022
Advisory Published
via GitHub·10:05 PM
Data Sourced
via GitHub·10:05 PM
DescriptionAffected Software
Data Sourced
via Packagist·10:05 PM
DescriptionSeverityAffected Software
Sep 18, 2024
CVE Published
via MITRE·02:47 PM
Data Sourced
via MITRE·02:47 PM
RemedyDescriptionSeverityWeakness

Frequently Asked Questions

1

What is the severity of CVE-2022-25769?

CVE-2022-25769 is considered a medium severity vulnerability due to its access restrictions not being correctly enforced.

2

How do I fix CVE-2022-25769?

To fix CVE-2022-25769, update Mautic to version 4.2.0 or later.

3

Which versions of Mautic are affected by CVE-2022-25769?

CVE-2022-25769 affects Mautic versions prior to 4.0.0 and between 4.0.0 and 4.2.0.

4

What happens if I don’t address CVE-2022-25769?

If not addressed, CVE-2022-25769 could allow unauthorized execution of PHP files, leading to potential security breaches.

5

Is CVE-2022-25769 related to specific file access issues?

Yes, CVE-2022-25769 is related to incorrect regex in the .htaccess file that fails to restrict access properly to certain PHP files.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203