CVE-2022-2602: Use After Free

Published Jan 8, 2024
·
Updated

iouring UAF Unix SCM garbage collection

Other sources

iouring UAF, Unix SCM garbage collection

— Launchpad

Affected Software

12 affected componentsFixes available
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft cbl2 kernel 5.15.153.1-1
Microsoft cbl2 kernel 5.15.180.1-1
Linux Linux kernel<=6.0.19
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=20.04
Canonical Ubuntu Linux=22.04
Canonical Ubuntu Linux=22.10
debian/linux<6.0.3-1
6.0.3-1
debian/linux<6.0.3-1
6.0.3-1
debian/linux<6.0.3-1
6.0.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.0.3-1

Event History

Oct 18, 2022
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Nov 18, 2022
Exploit Published
via GitHub·06:53 PM
Jan 8, 2024
CVE Published
via MITRE·05:56 PM
Data Sourced
via MITRE·05:56 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·06:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·06:15 PM
DescriptionSeverityAffected Software
Jan 13, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2022-2602?

CVE-2022-2602 is considered to have high severity due to the potential for exploitation through use-after-free vulnerabilities.

2

How do I fix CVE-2022-2602?

To mitigate CVE-2022-2602, it is recommended to upgrade to an unaffected version of the Linux kernel or apply the necessary patches provided by your distribution.

3

Which distributions are affected by CVE-2022-2602?

CVE-2022-2602 impacts multiple distributions including Debian and various versions of Ubuntu, specifically kernel versions up to 6.0.19.

4

Are there known exploits for CVE-2022-2602?

Yes, there are potential exploits for CVE-2022-2602 that can lead to privilege escalation and remote code execution.

5

What systems should I prioritize for patching against CVE-2022-2602?

Systems running outdated kernels such as those mentioned in the affected software list should be prioritized for patching against CVE-2022-2602.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203