CVE-2022-26354: Low severity Qemu Qemu vulnerability

Published Mar 11, 2022
·
Updated

A flaw was found in the vhost-vsock device of QEMU. In case of error, an invalid element was not detached from the virtqueue before freeing its memory, leading to memory leakage and other unexpected results. Affected QEMU versions <= 6.2.0.

Other sources

A flaw was found in the vhost-vsock device of QEMU. In case of error, vhostvsockcommonsendtransportreset() did not detach the invalid element from the virtqueue before freeing its memory, leading to memory leakage or other unexpected results.

Upstream commit: https://gitlab.com/qemu-project/qemu/-/commit/8d1b247f3748ac4078524130c6d7ae42b6140aaf

— Red Hat

Affected Software

7 affected componentsFixes available
Qemu Qemu<=6.2.0
Debian Debian Linux=9.0
Debian Debian Linux=10.0
debian/qemu<1:7.0+dfsg-1
1:7.0+dfsg-1
debian/qemu<1:7.0+dfsg-1
1:7.0+dfsg-1
debian/qemu<1:7.0+dfsg-1
1:7.0+dfsg-1
debian/qemu
1:7.2+dfsg-7+deb12u181:7.2+dfsg-7+deb12u151:10.0.13+ds-0+deb13u11:10.0.2+ds-2+deb13u11:11.1.2+ds-31:11.1.3+ds-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/qemu to a version that resolves this vulnerability.

    Fixed in 1:5.2+dfsg-11+deb11u3Fixed in 1:5.2+dfsg-11+deb11u2Fixed in 1:7.2+dfsg-7+deb12u12Fixed in 1:10.0.0~rc2+ds-2Fixed in 1:10.0.0~rc3+ds-2
  2. Upgrade

    Upgrade QEMU to a version that resolves this vulnerability.

    Patch 8d1b247f3748ac4078524130c6d7ae42b6140aaf

Event History

Mar 11, 2022
Data Sourced
via Red Hat·04:11 PM
DescriptionSeverityAffected Software
Mar 16, 2022
CVE Published
via MITRE·02:02 PM
Data Sourced
via MITRE·02:02 PM
DescriptionWeakness
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID of this flaw?

The vulnerability ID of this flaw is CVE-2022-26354.

2

What is the affected software?

The affected software includes QEMU versions <= 6.2.0, Debian Linux 9.0, Debian Linux 10.0, and certain versions of the QEMU package on Ubuntu and Debian.

3

What is the severity of CVE-2022-26354?

The severity of CVE-2022-26354 is low, with a severity value of 3.2.

4

What are the potential consequences of this vulnerability?

The potential consequences of this vulnerability include memory leakage and other unexpected results.

5

How can I fix CVE-2022-26354?

To fix CVE-2022-26354, you should update to a version of QEMU that is greater than 6.2.0, or apply the appropriate security patches for your operating system.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203