CVE-2022-28201: Medium severity MediaWiki MediaWiki vulnerability
An issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. Users with the editinterface permission can trigger infinite recursion, because a bare local interwiki is mishandled for the mainpage message.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.39.17-1+deb12u2Fixed in 1:1.43.9+dfsg-1~deb13u1Fixed in 1:1.43.11+dfsg-3 - Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.35.6-1
Event History
Frequently Asked Questions
What is the severity of CVE-2022-28201?
The severity of CVE-2022-28201 is medium with a severity value of 4.4.
How does CVE-2022-28201 affect MediaWiki?
CVE-2022-28201 affects MediaWiki versions before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2.
Who is affected by CVE-2022-28201?
Users of MediaWiki versions before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2 are affected by CVE-2022-28201.
How can CVE-2022-28201 be exploited?
The vulnerability can be exploited by users with the editinterface permission by triggering infinite recursion using a bare local interwiki for the mainpage message.
Are there any fixes available for CVE-2022-28201?
Yes, updates to MediaWiki versions 1.35.6, 1.36.4, and 1.37.2 have been released to fix CVE-2022-28201.