CVE-2022-2868: Input Validation

Published Aug 16, 2022
·
Updated

In libtiff's tiffcrop utility (tools/tiffcrop.c), a crafted file could supply an invalid cropwidth and/or croplength, and since these values were computed prior to the sanity check, invalid values could later cause out-of-bounds reads in reverseSamples16bits().

References: 1. https://gitlab.com/libtiff/libtiff/-/issues/335 2. https://gitlab.com/libtiff/libtiff/-/mergerequests/294/diffs?commitid=b258ed69a485a9cfb299d9f060eb2a46c54e5903

Other sources

LibTIFF is vulnerable to a denial of service, caused by improper validation of user supplied input that leads to an out-of-bounds read. By persuading a victim to open a specially-crafted file, a remote attacker could exploit this vulnerability to cause a denial of service.

— IBM

libtiff's tiffcrop utility has a improper input validation flaw that can lead to out of bounds read and ultimately cause a crash if an attacker is able to supply a crafted file to tiffcrop.

Affected Software

24 affected componentsFixes available
redhat/libtiff<4.4.0
4.4.0
IBM Cognos Analytics<=12.0.0-12.0.3
IBM Cognos Analytics<=11.2.0-11.2.4 FP4
LibTIFF libtiff<4.4.0
Fedoraproject Fedora=35
Fedoraproject Fedora=36
Debian Debian Linux=10.0
Debian Debian Linux=11.0
debian/tiff<4.4.0~rc1-1
4.4.0~rc1-1
debian/tiff<4.4.0~rc1-1
4.4.0~rc1-1
debian/tiff<4.4.0~rc1-1
4.4.0~rc1-1
debian/tiff
4.5.0-6+deb12u44.7.0-3+deb13u34.7.2-1
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0
alpine/tiff<4.4.0-r0
4.4.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/tiff to a version that resolves this vulnerability.

    Fixed in 4.1.0+git191117-2~deb10u8Fixed in 4.2.0-1+deb11u4Fixed in 4.2.0-1+deb11u5Fixed in 4.5.0-6+deb12u1Fixed in 4.5.1+git230720-3
  2. Upgrade

    Upgrade redhat/libtiff to a version that resolves this vulnerability.

    Fixed in 4.4.0

Event History

Aug 17, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via NVD·10:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-2868?

CVE-2022-2868 is a vulnerability in libtiff's tiffcrop utility that allows for out of bounds read and can cause a crash if a crafted file is supplied to tiffcrop.

2

What is the severity of CVE-2022-2868?

The severity of CVE-2022-2868 is medium with a CVSS score of 5.5.

3

How does CVE-2022-2868 affect libtiff?

CVE-2022-2868 affects libtiff versions up to and exclusive of 4.4.0.

4

How do I fix CVE-2022-2868 on Red Hat?

To fix CVE-2022-2868 on Red Hat, update to libtiff version 4.4.0 or later.

5

How do I fix CVE-2022-2868 on Debian Linux?

To fix CVE-2022-2868 on Debian Linux, update to tiff version 4.1.0+git191117-2~deb10u8 or later.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203