CVE-2022-28893: Use After Free
A use-after-free flaw was found in net/sunrpc/xprt.c in the Remote Procedure Call (SunRPC) protocol in the Linux kernel. This flaw could allow a local attacker to crash, and this may even lead to a kernel information leak problem.
References:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1a3b1bba7c7a5eb8a11513cf88427cb9d77bc60a http://www.openwall.com/lists/oss-security/2022/04/11/4 http://www.openwall.com/lists/oss-security/2022/04/11/3
Other sources
A use-after-free flaw was found in the Linux kernel’s net/sunrpc/xprt.c function in the Remote Procedure Call (SunRPC) protocol. This flaw allows a local attacker to crash the system, leading to a kernel information leak issue.
The SUNRPC subsystem in the Linux kernel through 5.17.2 can call xsxprtfree before ensuring that sockets are in the intended state.
— Ubuntu
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-425.3.1.rt7.213.el8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-425.3.1.el8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:5.14.0-162.6.1.el9_1 - Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:5.14.0-162.6.1.rt21.168.el9_1 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.18 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.17.3-1 - Configuration
Add the sunrpc kernel module to the blacklist file to prevent it from loading automatically during boot.
Linux kernel SUNRPC driver kernel module blacklist = sunrpc
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2022-28893?
CVE-2022-28893 has a severity rating that could lead to local crashes and potential information leaks.
How do I fix CVE-2022-28893?
To fix CVE-2022-28893, update your Linux kernel to versions 0:4.18.0-425.3.1.rt7.213.el8, 0:4.18.0-425.3.1.el8, 0:5.14.0-162.6.1.el9_1, or higher as specified.
What systems are affected by CVE-2022-28893?
CVE-2022-28893 affects various versions of the Linux kernel across multiple distributions, including certain versions of Red Hat and Debian.
Can CVE-2022-28893 be exploited remotely?
CVE-2022-28893 is a local vulnerability and requires local access to exploit.
Who can be impacted by CVE-2022-28893?
Local attackers on affected Linux systems may exploit CVE-2022-28893 to cause crashes or information leaks.