CVE-2022-29156: Double Free
drivers/infiniband/ulp/rtrs/rtrs-clt.c in the Linux kernel before 5.16.12 has a double free related to rtrscltdevrelease.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.16.12-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 5.16.12
Event History
Frequently Asked Questions
What is the severity of CVE-2022-29156?
CVE-2022-29156 has been classified as a medium severity vulnerability due to the potential for a double free condition.
How do I fix CVE-2022-29156?
To fix CVE-2022-29156, upgrade to a patched kernel version such as 5.16.12 or later.
Which Linux kernel versions are affected by CVE-2022-29156?
CVE-2022-29156 affects Linux kernel versions prior to 5.16.12, including versions 5.10.x and some 5.15.x branches.
What vulnerabilities are associated with CVE-2022-29156?
CVE-2022-29156 is specifically related to a double free vulnerability in the kernel's infinite-band drivers.
Can CVE-2022-29156 be exploited remotely?
Yes, CVE-2022-29156 has the potential to be exploited remotely under certain conditions due to its nature involving client-server interactions.