CVE-2022-29178: Incorrect Default Permissions in Cilium
Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Cilium prior to versions 1.9.16, 1.10.11, and 1.11.15 contains an incorrect default permissions vulnerability. Operating Systems with users belonging to the group ID 1000 can access the API of Cilium via Unix domain socket available on the host where Cilium is running. This could allow malicious users to compromise integrity as well as system availability on that host. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. A potential workaround is to modify Cilium's DaemonSet to run with a certain command, which can be found in the GitHub Security Advisory for this vulnerability.
Affected Software
Event History
Frequently Asked Questions
What is CVE-2022-29178?
CVE-2022-29178 is a vulnerability in Cilium, an open-source software for providing and securing network connectivity, which allows incorrect default permissions on certain operating systems.
What is the severity of CVE-2022-29178?
The severity of CVE-2022-29178 is high, with a CVSS score of 8.2.
How does CVE-2022-29178 affect Cilium?
CVE-2022-29178 affects Cilium versions 1.9.16, 1.10.11, and 1.11.15, where the incorrect default permissions vulnerability exists.
Which operating systems are affected by CVE-2022-29178?
Operating systems with users belonging to the group ID 1000 may be affected by CVE-2022-29178 when running Cilium versions mentioned.
How can I fix CVE-2022-29178?
To fix CVE-2022-29178, it is recommended to upgrade Cilium to versions 1.9.16, 1.10.11, or 1.11.15 or later, as the vulnerability has been addressed in these releases.