CVE-2022-29179: Improper Privilege Management in Cilium
Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Prior to versions 1.9.16, 1.10.11, and 1.11.15, if an attacker is able to perform a container escape of a container running as root on a host where Cilium is installed, the attacker can escalate privileges to cluster admin by using Cilium's Kubernetes service account. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. There are no known workarounds available.
Affected Software
Event History
Frequently Asked Questions
What is CVE-2022-29179?
CVE-2022-29179 is a vulnerability in Cilium, an open source software for network connectivity and load balancing, that allows an attacker to perform a container escape and gain root access.
What is the severity of CVE-2022-29179?
CVE-2022-29179 has a severity score of 8.2, which is classified as high severity.
Which versions of Cilium are affected by CVE-2022-29179?
Versions 1.9.16, 1.10.0 to 1.10.11 (excluding 1.10.11), and 1.11.0 to 1.11.5 (excluding 1.11.5) of Cilium are affected by CVE-2022-29179.
How can an attacker exploit CVE-2022-29179?
An attacker can exploit CVE-2022-29179 by performing a container escape of a container running as root on a host where Cilium is installed.
How do I mitigate CVE-2022-29179?
To mitigate CVE-2022-29179, it is recommended to update Cilium to versions 1.9.16, 1.10.11, or 1.11.5 or later, as the vulnerability has been fixed in these versions.