CVE-2022-29263: High severity F5 Access Policy Manager Clients vulnerability
On F5 BIG-IP APM 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior to 13.1.5, and all versions of 12.1.x and 11.6.x, as well as F5 BIG-IP APM Clients 7.x versions prior to 7.2.1.5, the BIG-IP Edge Client Component Installer Service does not use best practice while saving temporary files. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
F5 BIG-IP APMto a version that resolves this vulnerability.Fixed in 16.1.2.2 - Upgrade
Upgrade
F5 BIG-IP APMto a version that resolves this vulnerability.Fixed in 15.1.5.1 - Upgrade
Upgrade
F5 BIG-IP APMto a version that resolves this vulnerability.Fixed in 14.1.4.6 - Upgrade
Upgrade
F5 BIG-IP APMto a version that resolves this vulnerability.Fixed in 13.1.5 - Upgrade
Upgrade
F5 BIG-IP APM Clientsto a version that resolves this vulnerability.Fixed in 7.2.1.5
Event History
Frequently Asked Questions
What is the severity of CVE-2022-29263?
The severity of CVE-2022-29263 is high.
What versions of F5 BIG-IP APM are affected by CVE-2022-29263?
F5 BIG-IP APM 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior to 13.1.5, and all versions of 12.1.x and 11.6.x are affected by CVE-2022-29263.
What is the vulnerability description of CVE-2022-29263?
CVE-2022-29263 is a vulnerability in the BIG-IP Edge Client Component Installer that allows remote code execution.
How do I fix CVE-2022-29263?
To fix CVE-2022-29263, update to F5 BIG-IP APM 16.1.2.2, 15.1.5.1, or later versions.
Where can I find more information about CVE-2022-29263?
More information about CVE-2022-29263 can be found at https://support.f5.com/csp/article/K33552735.