CVE-2022-29869: Medium severity Samba cifs-utils vulnerability
cifs-utils through 6.14, with verbose logging, can cause an information leak when a file contains = (equal sign) characters but is not a valid credentials file.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/cifs-utilsto a version that resolves this vulnerability.Fixed in 2:7.0-2Fixed in 2:7.4-1Fixed in 2:7.4-1+deb13u2Fixed in 2:7.9-1 - Upgrade
Upgrade
alpine/cifs-utilsto a version that resolves this vulnerability.Fixed in 6.15-r0 - Upgrade
Upgrade
debian/cifs-utilsto a version that resolves this vulnerability.Fixed in 2:6.14-1.1
Event History
Frequently Asked Questions
What is CVE-2022-29869?
CVE-2022-29869 is a vulnerability in cifs-utils through version 6.14 that can cause an information leak when a file contains = (equal sign) characters but is not a valid credentials file.
How does CVE-2022-29869 affect Samba Cifs-utils?
CVE-2022-29869 affects Samba Cifs-utils versions up to and excluding 6.15.
Which operating systems are affected by CVE-2022-29869?
CVE-2022-29869 affects Fedora 34, Fedora 35, Fedora 36, Debian Linux 9.0, Debian Linux 10.0, and Debian Linux 11.0.
What is the severity of CVE-2022-29869?
CVE-2022-29869 has a severity rating of 5.3 (Medium).
How can I fix CVE-2022-29869?
To fix CVE-2022-29869, update cifs-utils to version 2:6.8-2+deb10u1, 2:6.11-3.1+deb11u1, or 2:7.0-2.