CVE-2022-31090: CURLOPT_HTTPAUTH option not cleared on change of origin

Published Jun 20, 2022
·
Updated

Impact

Authorization headers on requests are sensitive information. When using our Curl handler, it is possible to use the CURLOPTHTTPAUTH option to specify an Authorization header. On making a request which responds with a redirect to a URI with a different origin, if we choose to follow it, we should remove the CURLOPTHTTPAUTH and CURLOPTUSERPWD options before continuing, stopping curl from appending the Authorization header to the new request. Previously, we would only consider a change in host. Now, we consider any change in host, port or scheme to be a change in origin.

Patches

Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port.

Workarounds

If you do not require or expect redirects to be followed, one should simply disable redirects all together. Alternatively, one can specify to use the Guzzle stream handler backend, rather than curl.

References

RFC9110 Section 15.4 CVE-2022-27776

For more information

If you have any questions or comments about this advisory, please get in touch with us in #guzzle on the PHP HTTP Slack. Do not report additional security advisories in that public channel, however - please follow our vulnerability reporting process.

Other sources

CURLOPTHTTPAUTH option not cleared on change of origin

Guzzle, an extensible PHP HTTP client. Authorization headers on requests are sensitive information. In affected versions when using our Curl handler, it is possible to use the CURLOPTHTTPAUTH option to specify an Authorization header. On making a request which responds with a redirect to a URI with a different origin (change in host, scheme or port), if we choose to follow it, we should remove the CURLOPTHTTPAUTH option before continuing, stopping curl from appending the Authorization header to the new request. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port. If you do not require or expect redirects to be followed, one should simply disable redirects all together. Alternatively, one can specify to use the Guzzle steam handler backend, rather than curl.

Affected Software

16 affected componentsFixes available
composer/guzzlehttp/guzzle>=7, <7.4.5, >=4, <6.5.8
composer/guzzlehttp/guzzle>=7.0.0<7.4.5
7.4.5
composer/guzzlehttp/guzzle<6.5.8
6.5.8
Guzzlephp Guzzle<6.5.8
Guzzlephp Guzzle>=7.0.0<7.4.5
Debian Debian Linux=11.0
composer/guzzlehttp/guzzle>=7, <7.4.5
7.4.5
composer/guzzlehttp/guzzle>=4, <6.5.8
6.5.8
debian/guzzle<7.4.5-1
7.4.5-1
debian/guzzle<7.4.5-1
7.4.5-1
debian/guzzle<7.4.5-1
7.4.5-1
debian/mediawiki<1:1.35.7-1
1:1.35.7-1
debian/mediawiki<1:1.35.7-1
1:1.35.7-1
debian/mediawiki<1:1.35.7-1
1:1.35.7-1
debian/guzzle
7.4.5-17.9.2-0.18.3.1-3
debian/mediawiki
1:1.39.17-1+deb12u21:1.43.9+dfsg-1~deb13u11:1.43.11+dfsg-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/guzzlehttp/guzzle to a version that resolves this vulnerability.

    Fixed in 7.4.5
  2. Upgrade

    Upgrade composer/guzzlehttp/guzzle to a version that resolves this vulnerability.

    Fixed in 6.5.8
  3. Upgrade

    Upgrade debian/guzzle to a version that resolves this vulnerability.

    Fixed in 7.4.5-1
  4. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.35.7-1
  5. Upgrade

    Upgrade debian/guzzle to a version that resolves this vulnerability.

    Fixed in 7.4.5-1Fixed in 7.9.2-0.1Fixed in 8.3.1-3
  6. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.39.17-1+deb12u2Fixed in 1:1.43.9+dfsg-1~deb13u1Fixed in 1:1.43.11+dfsg-3
  7. Upgrade

    Upgrade Guzzle to a version that resolves this vulnerability.

    Fixed in 7.4.5
  8. Upgrade

    Upgrade Guzzle to a version that resolves this vulnerability.

    Fixed in 6.5.8
  9. Configuration

    Use the Guzzle stream handler backend instead of the Curl handler.

    Guzzle HTTP handler backend = stream
  10. Configuration

    Disable redirects if following redirects is not required.

    Guzzle redirects = disabled
  11. Configuration

    When following a redirect to a different origin, remove the CURLOPT_HTTPAUTH and CURLOPT_USERPWD options before continuing.

    Guzzle Curl handler CURLOPT_HTTPAUTH and CURLOPT_USERPWD = removed before continuing

Event History

Jun 20, 2022
Advisory Published
via Packagist·10:16 PM
Data Sourced
via Packagist·10:16 PM
DescriptionSeverityAffected Software
Advisory Published
10:24 PM
Jun 27, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·10:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID?

The vulnerability ID is CVE-2022-31090.

2

What is the impact of the vulnerability?

The impact of the vulnerability is sensitive information exposure.

3

Which software versions are affected by this vulnerability?

The software versions affected are Guzzlephp Guzzle up to version 6.5.8, Guzzlephp Guzzle versions between 7.0.0 and 7.4.5, and Debian Debian Linux version 11.0.

4

How severe is the vulnerability?

The vulnerability has a severity score of 7.7 (high).

5

How can I fix the vulnerability?

To fix the vulnerability, update to Guzzlephp Guzzle version 7.4.5 or later, or apply the appropriate security patches for Debian Debian Linux version 11.0.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203