CVE-2022-32292: Buffer Overflow

Published Aug 3, 2022
·
Updated

In ConnMan through 1.41, remote attackers able to send HTTP requests to the gweb component are able to exploit a heap-based buffer overflow in receiveddata to execute code.

Affected Software

10 affected componentsFixes available
ubuntu/connman<1.36-2ubuntu0.1
1.36-2ubuntu0.1
ubuntu/connman<1.36-2.3ubuntu0.1
1.36-2.3ubuntu0.1
ubuntu/connman<1.35-6ubuntu0.1~
1.35-6ubuntu0.1~
ubuntu/connman<1.21-1.2+
1.21-1.2+
Intel Connman<=1.41
Debian Debian Linux=11.0
debian/connman<1.41-2
1.41-2
debian/connman<1.41-2
1.41-2
debian/connman<1.41-2
1.41-2
debian/connman
1.41-31.44-32.0-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2ubuntu0.1
  2. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.3ubuntu0.1
  3. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.35-6ubuntu0.1~
  4. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.21-1.2+
  5. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.41-3Fixed in 1.44-3Fixed in 2.0-2
  6. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.41-2

Event History

Aug 3, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software
Aug 10, 2022
Data Sourced
08:15 PM
SeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID?

The vulnerability ID is CVE-2022-32292.

2

What is the title of the vulnerability?

The title of the vulnerability is 'In ConnMan through 1.41 remote attackers able to send HTTP requests to the gweb component are able to...'

3

What is the description of the vulnerability?

The description of the vulnerability is 'In ConnMan through 1.41, remote attackers able to send HTTP requests to the gweb component are able to exploit a heap-based buffer overflow in received_data to execute code.'

4

What software versions are affected by this vulnerability?

The affected software versions are 1.36-2.1~deb10u5, 1.36-2.2+deb11u1, 1.36-2.2+deb11u2, and 1.41-3.

5

What is the fix for this vulnerability?

The fix for this vulnerability depends on the affected software package. Please refer to the provided references for the specific remedy.

6

What are the references for this vulnerability?

The references for this vulnerability are 'https://lore.kernel.org/connman/20220801080043.4861-5-wagi@monom.org/', 'https://bugzilla.suse.com/show_bug.cgi?id=1200189', and 'https://www.debian.org/security/2022/dsa-5231'.

7

What is the Common Weakness Enumeration (CWE) ID for this vulnerability?

The Common Weakness Enumeration (CWE) ID for this vulnerability is CWE-119.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203