CVE-2022-32293: Use After Free

Published Aug 3, 2022
·
Updated

In ConnMan through 1.41, a man-in-the-middle attack against a WISPR HTTP query could be used to trigger a use-after-free in WISPR handling, leading to crashes or code execution.

Affected Software

10 affected componentsFixes available
ubuntu/connman<1.35-6ubuntu0.1~
1.35-6ubuntu0.1~
ubuntu/connman<1.36-2ubuntu0.1
1.36-2ubuntu0.1
ubuntu/connman<1.36-2.3ubuntu0.1
1.36-2.3ubuntu0.1
ubuntu/connman<1.21-1.2+
1.21-1.2+
Intel Connman<=1.41
Debian Debian Linux=11.0
debian/connman<1.41-2
1.41-2
debian/connman<1.41-2
1.41-2
debian/connman<1.41-2
1.41-2
debian/connman
1.41-31.44-32.0-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.35-6ubuntu0.1~
  2. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2ubuntu0.1
  3. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.3ubuntu0.1
  4. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.21-1.2+
  5. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.41-3Fixed in 1.44-3Fixed in 2.0-2
  6. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.41-2

Event History

Aug 3, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-32293?

CVE-2022-32293 is a vulnerability in ConnMan through 1.41 that could allow a man-in-the-middle attack against a WISPR HTTP query, leading to crashes or code execution.

2

How severe is CVE-2022-32293?

CVE-2022-32293 has a severity rating of 8.1 (high).

3

Which software versions are affected by CVE-2022-32293?

The versions of ConnMan affected by CVE-2022-32293 include: 1.36-2.1~deb10u5, 1.36-2.2+deb11u2, and 1.41-3.

4

Is there a fix available for CVE-2022-32293?

Yes, the following fixed versions are available: 1.36-2.1~deb10u2 for debian/connman, 1.35-6ubuntu0.1~ for ubuntu/connman (bionic), 1.36-2ubuntu0.1 for ubuntu/connman (focal), and 1.36-2.3ubuntu0.1 for ubuntu/connman (jammy).

5

What is the Common Weakness Enumeration (CWE) ID for CVE-2022-32293?

The CWE ID for CVE-2022-32293 is CWE-416.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203