CVE-2022-34673: Integer Overflow
NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where an out-of-bounds array access may lead to denial of service, information disclosure, or data tampering.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6 - Upgrade
Upgrade
debian/nvidia-open-gpu-kernel-modulesto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 550.163.01-2Fixed in 550.163.01-4.1 - Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 515.86.01-1 - Upgrade
Upgrade
debian/nvidia-open-gpu-kernel-modulesto a version that resolves this vulnerability.Fixed in 515.86.01-1
Event History
Frequently Asked Questions
What is the vulnerability ID of this NVIDIA GPU Display Driver for Linux vulnerability?
The vulnerability ID of this NVIDIA GPU Display Driver for Linux vulnerability is CVE-2022-34673.
What is the severity level of CVE-2022-34673?
The severity level of CVE-2022-34673 is high, with a severity value of 7.3.
What is affected by CVE-2022-34673?
The NVIDIA GPU Display Driver for Linux versions up to and including 515.86.01 are affected by CVE-2022-34673.
What are the possible impacts of CVE-2022-34673?
CVE-2022-34673 may lead to denial of service, information disclosure, or data tampering.
How can I fix CVE-2022-34673?
To fix CVE-2022-34673, update to a version of the NVIDIA GPU Display Driver for Linux that is newer than 515.86.01.