CVE-2022-34674: Infoleak
NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer handler, where a helper function maps more physical pages than were requested, which may lead to undefined behavior or an information leak.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-legacy-390xxto a version that resolves this vulnerability.Fixed in 390.157-16 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-teslato a version that resolves this vulnerability.Fixed in 525.147.05-15~deb12u1Fixed in 525.147.05-19 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-450to a version that resolves this vulnerability.Fixed in 450.248.02-14 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-460to a version that resolves this vulnerability.Fixed in 460.106.00-24 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-470to a version that resolves this vulnerability.Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10 - Upgrade
Upgrade
debian/nvidia-open-gpu-kernel-modulesto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 550.163.01-2Fixed in 550.163.01-4.1 - Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 510.108.03-1 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-teslato a version that resolves this vulnerability.Fixed in 510.108.03-1 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-470to a version that resolves this vulnerability.Fixed in 470.161.03-1 - Upgrade
Upgrade
debian/nvidia-open-gpu-kernel-modulesto a version that resolves this vulnerability.Fixed in 515.86.01-1
Event History
Frequently Asked Questions
What is CVE-2022-34674?
CVE-2022-34674 is a vulnerability in the NVIDIA GPU Display Driver for Linux that can lead to undefined behavior or an information leak.
What software is affected by CVE-2022-34674?
The NVIDIA GPU Display Driver for Linux versions 390 to 525.60.11 are affected by CVE-2022-34674.
What is the severity of CVE-2022-34674?
CVE-2022-34674 has a severity rating of 6.8 (medium).
How can I fix CVE-2022-34674?
To fix CVE-2022-34674, update your NVIDIA GPU Display Driver for Linux to a version higher than 525.60.11.
Where can I find more information about CVE-2022-34674?
More information about CVE-2022-34674 can be found at the following references: [link1](https://lists.debian.org/debian-lts-announce/2023/05/msg00010.html), [link2](https://nvidia.custhelp.com/app/answers/detail/a_id/5415), [link3](https://security.gentoo.org/glsa/202310-02).