CVE-2022-34679: Null Pointer Dereference
NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer handler, where an unhandled return value can lead to a null-pointer dereference, which may lead to denial of service.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-teslato a version that resolves this vulnerability.Fixed in 525.147.05-15~deb12u1Fixed in 525.147.05-19 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-450to a version that resolves this vulnerability.Fixed in 450.248.02-14 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-460to a version that resolves this vulnerability.Fixed in 460.106.00-24 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-470to a version that resolves this vulnerability.Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10 - Upgrade
Upgrade
debian/nvidia-open-gpu-kernel-modulesto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 550.163.01-2Fixed in 550.163.01-4.1 - Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 510.108.03-1 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-teslato a version that resolves this vulnerability.Fixed in 510.108.03-1 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-470to a version that resolves this vulnerability.Fixed in 470.161.03-1 - Upgrade
Upgrade
debian/nvidia-open-gpu-kernel-modulesto a version that resolves this vulnerability.Fixed in 515.86.01-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this NVIDIA GPU vulnerability?
The vulnerability ID for this NVIDIA GPU vulnerability is CVE-2022-34679.
What is the severity rating of CVE-2022-34679?
The severity rating of CVE-2022-34679 is medium.
What can happen if this vulnerability is exploited?
If this vulnerability is exploited, it can lead to a null-pointer dereference, which may result in denial of service.
Which software versions are affected by CVE-2022-34679?
NVIDIA Virtual GPU versions up to 11.11, versions between 12.0 and 13.6, and versions between 14.0 and 14.4 are affected by CVE-2022-34679.
How can I fix CVE-2022-34679?
To fix CVE-2022-34679, it is recommended to update to a version of NVIDIA Virtual GPU that is not vulnerable.