CVE-2022-34684: High severity Nvidia Virtual GPU vulnerability

Published Dec 30, 2022
·
Updated

NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where an off-by-one error may lead to data tampering or information disclosure.

Affected Software

27 affected componentsFixes available
Nvidia Virtual GPU<11.11
Nvidia Virtual GPU>=12.0<13.6
Nvidia Virtual GPU>=14.0<14.4
Citrix Hypervisor
Linux Linux kernel
redhat Enterprise Linux Kernel-based Virtual Machine
VMware vSphere
Nvidia Cloud Gaming<525.60.11
Nvidia Cloud Gaming<525.60.12
Nvidia Gpu Display Driver Linux>=510<510.108.03
Nvidia Gpu Display Driver Linux>=515<515.86.01
Nvidia Geforce
Nvidia Nvs
Nvidia Quadro
Nvidia Rtx
Nvidia Tesla
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers-tesla<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers-tesla-470<470.161.03-1
470.161.03-1
debian/nvidia-open-gpu-kernel-modules<515.86.01-1
515.86.01-1
debian/nvidia-open-gpu-kernel-modules<515.86.01-1
515.86.01-1
debian/nvidia-graphics-drivers
535.261.03-1535.309.01-0+deb12u1550.163.01-2550.163.01-5.1550.163.01-6
debian/nvidia-graphics-drivers-tesla
525.147.05-15~deb12u1525.147.05-19
debian/nvidia-graphics-drivers-tesla-470
470.256.02-1~deb12u1470.256.02-10
debian/nvidia-open-gpu-kernel-modules
535.261.03-1550.163.01-2550.163.01-4.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6
  2. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla to a version that resolves this vulnerability.

    Fixed in 525.147.05-15~deb12u1Fixed in 525.147.05-19
  3. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10
  4. Upgrade

    Upgrade debian/nvidia-open-gpu-kernel-modules to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 550.163.01-2Fixed in 550.163.01-4.1
  5. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 510.108.03-1
  6. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla to a version that resolves this vulnerability.

    Fixed in 510.108.03-1
  7. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.161.03-1
  8. Upgrade

    Upgrade debian/nvidia-open-gpu-kernel-modules to a version that resolves this vulnerability.

    Fixed in 515.86.01-1

Event History

Dec 30, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·11:15 PM
DescriptionSeverityAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID of this NVIDIA GPU Display Driver vulnerability?

The vulnerability ID is CVE-2022-34684.

2

What is the severity level of CVE-2022-34684?

The severity level of CVE-2022-34684 is high with a score of 7.1.

3

What is the affected software for CVE-2022-34684?

The affected software for CVE-2022-34684 includes Nvidia Virtual Gpu (up to version 11.11), Nvidia Virtual Gpu (between versions 12.0 and 13.6), Nvidia Virtual Gpu (between versions 14.0 and 14.4), and Nvidia Gpu Display Driver (between versions 510 and 510.108.03 on Linux).

4

What is the description of CVE-2022-34684?

CVE-2022-34684 is a vulnerability in the NVIDIA GPU Display Driver for Linux that allows an off-by-one error, potentially leading to data tampering or information disclosure.

5

Where can I find more information about CVE-2022-34684?

You can find more information about CVE-2022-34684 on the NVIDIA website at https://nvidia.custhelp.com/app/answers/detail/a_id/5415 and the Gentoo Linux Security Advisory website at https://security.gentoo.org/glsa/202310-02.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203