CVE-2022-34835: Buffer Overflow

Published Jun 29, 2022
·
Updated

In Das U-Boot through 2022.07-rc5, an integer signedness error and resultant stack-based buffer overflow in the "i2c md" command enables the corruption of the return address pointer of the doi2cmd function.

Affected Software

13 affected componentsFixes available
ubuntu/u-boot<2020.10+dfsg-1ubuntu0~18.04.3
2020.10+dfsg-1ubuntu0~18.04.3
ubuntu/u-boot<2021.01+dfsg-3ubuntu0~20.04.5
2021.01+dfsg-3ubuntu0~20.04.5
ubuntu/u-boot<2022.01+dfsg-2ubuntu2.3
2022.01+dfsg-2ubuntu2.3
DENX U-Boot<2022.07
DENX U-Boot=2022.07-rc1
DENX U-Boot=2022.07-rc2
DENX U-Boot=2022.07-rc3
DENX U-Boot=2022.07-rc4
DENX U-Boot=2022.07-rc5
debian/u-boot<2022.07+dfsg-1
2022.07+dfsg-1
debian/u-boot<2022.07+dfsg-1
2022.07+dfsg-1
debian/u-boot<2022.07+dfsg-1
2022.07+dfsg-1
debian/u-boot
2023.01+dfsg-2+deb12u32025.01-3+deb13u12025.01-3.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/u-boot to a version that resolves this vulnerability.

    Fixed in 2020.10+dfsg-1ubuntu0~18.04.3
  2. Upgrade

    Upgrade ubuntu/u-boot to a version that resolves this vulnerability.

    Fixed in 2021.01+dfsg-3ubuntu0~20.04.5
  3. Upgrade

    Upgrade ubuntu/u-boot to a version that resolves this vulnerability.

    Fixed in 2022.01+dfsg-2ubuntu2.3
  4. Upgrade

    Upgrade debian/u-boot to a version that resolves this vulnerability.

    Fixed in 2023.01+dfsg-2+deb12u3Fixed in 2025.01-3+deb13u1Fixed in 2025.01-3.2
  5. Upgrade

    Upgrade debian/u-boot to a version that resolves this vulnerability.

    Fixed in 2022.07+dfsg-1

Event History

Jun 29, 2022
CVE Published
via MITRE·11:48 PM
Data Sourced
via MITRE·11:48 PM
Description
Jun 30, 2022
Data Sourced
via NVD·12:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·12:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID of this issue?

The vulnerability ID is CVE-2022-34835.

2

What is the severity level of CVE-2022-34835?

CVE-2022-34835 has a severity level of 9.8 (Critical).

3

Which software versions are affected by CVE-2022-34835?

The affected software versions are DENX U-Boot 2022.07, 2022.07-rc1, 2022.07-rc2, 2022.07-rc3, 2022.07-rc4, and 2022.07-rc5.

4

What is the description of CVE-2022-34835?

CVE-2022-34835 is a vulnerability in Das U-Boot that allows for an integer signedness error and stack-based buffer overflow in the "i2c md" command, leading to the corruption of the return address pointer of the do_i2c_md function.

5

How can I fix CVE-2022-34835?

Upgrade to a patched version of DENX U-Boot that includes the fix for CVE-2022-34835.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203