CVE-2022-34912: Medium severity MediaWiki MediaWiki vulnerability

Published Jul 2, 2022
·
Updated

An issue was discovered in MediaWiki before 1.37.3 and 1.38.x before 1.38.1. The contributions-title, used on Special:Contributions, is used as page title without escaping. Hence, in a non-default configuration where a username contains HTML entities, it won't be escaped.

Affected Software

10 affected componentsFixes available
MediaWiki MediaWiki<1.37.3
MediaWiki MediaWiki=1.38.0
MediaWiki MediaWiki=1.38.0-rc0
MediaWiki MediaWiki=1.38.0-rc1
Fedoraproject Fedora=36
Fedoraproject Fedora=37
debian/mediawiki<1:1.35.7-1
1:1.35.7-1
debian/mediawiki<1:1.35.7-1
1:1.35.7-1
debian/mediawiki<1:1.35.7-1
1:1.35.7-1
debian/mediawiki
1:1.39.17-1+deb12u21:1.43.9+dfsg-1~deb13u11:1.43.11+dfsg-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.39.17-1+deb12u2Fixed in 1:1.43.9+dfsg-1~deb13u1Fixed in 1:1.43.11+dfsg-3
  2. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.35.7-1
  3. Upgrade

    Upgrade MediaWiki to a version that resolves this vulnerability.

    Fixed in 1.37.3
  4. Upgrade

    Upgrade MediaWiki to a version that resolves this vulnerability.

    Fixed in 1.38.1

Event History

Jul 2, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2022-34912?

CVE-2022-34912 has been classified with a high severity due to its potential for cross-site scripting (XSS) attacks.

2

How do I fix CVE-2022-34912?

To remediate CVE-2022-34912, upgrade to MediaWiki version 1.37.3, 1.38.1, or later.

3

What software is affected by CVE-2022-34912?

CVE-2022-34912 affects MediaWiki versions prior to 1.37.3 and 1.38.x before 1.38.1.

4

Can CVE-2022-34912 allow for remote code execution?

CVE-2022-34912 does not directly allow for remote code execution, but it can lead to cross-site scripting vulnerabilities.

5

Is there a workaround for CVE-2022-34912?

Currently, the recommended approach for CVE-2022-34912 is to update to the patched versions rather than implementing a workaround.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203