CVE-2022-36946: High severity Linux Linux kernel vulnerability

Published Jul 26, 2022
·
Updated

A Linux Kernel flaw found in the net/netfilter/nfnetlinkqueue.c. If local user creates netfilter rule that truncates the packet below the header size, the skbpull() will result in a malformed skb (skb->len < 0). As result, denial of service could happen after incorrect check in nfqnlmangle function.

Fixes: 7af4cc3fa158 ("[NETFILTER]: Add "nfnetlinkqueue" netfilter queue handler over nfnetlink")

Reference: https://lore.kernel.org/all/20220726104206.2036-1-fw@strlen.de/t/

Other sources

A memory corruption flaw was found in the Linux kernel’s Netfilter subsystem in the way a local user uses the libnetfilterqueue when analyzing a corrupted network packet. This flaw allows a local user to crash the system or a remote user to crash the system when the libnetfilterqueue is used by a local user.

nfqnlmangle in net/netfilter/nfnetlinkqueue.c in the Linux kernel through 5.18.14 allows remote attackers to cause a denial of service (panic) because, in the case of an nfqueue verdict with a one-byte nftapayload attribute, an skbpull can encounter a negative skb->len.

— Ubuntu

Affected Software

23 affected componentsFixes available
redhat/kernel-rt<0:4.18.0-425.3.1.rt7.213.el8
0:4.18.0-425.3.1.rt7.213.el8
redhat/kernel<0:4.18.0-425.3.1.el8
0:4.18.0-425.3.1.el8
redhat/kernel<0:5.14.0-162.6.1.el9_1
0:5.14.0-162.6.1.el9_1
redhat/kernel-rt<0:5.14.0-162.6.1.rt21.168.el9_1
0:5.14.0-162.6.1.rt21.168.el9_1
Linux Linux kernel>=2.6.14<4.9.326
Linux Linux kernel>=4.10<4.14.291
Linux Linux kernel>=4.15<4.19.255
Linux Linux kernel>=4.20<5.4.209
Linux Linux kernel>=5.5<5.10.135
Linux Linux kernel>=5.11<5.15.59
Linux Linux kernel>=5.16<5.18.16
Debian Debian Linux=10.0
Debian Debian Linux=11.0
NetApp Active Iq Unified Manager Vmware Vsphere
NetApp Solidfire \& Hci Management Node
NetApp Solidfire \& Hci Storage Node
NetApp Solidfire Enterprise Sds
NetApp Hci Compute Node
redhat/kernel<5.18.16
5.18.16
debian/linux<5.18.16-1
5.18.16-1
debian/linux<5.18.16-1
5.18.16-1
debian/linux<5.18.16-1
5.18.16-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-425.3.1.rt7.213.el8
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-425.3.1.el8
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-162.6.1.el9_1
  4. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-162.6.1.rt21.168.el9_1
  5. Upgrade

    Upgrade redhat/Kernel to a version that resolves this vulnerability.

    Fixed in 5.18.16
  6. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.18.16-1
  7. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  8. Configuration

    Prevent the nfnetlink_queue module from loading automatically by adding nfnetlink_queue to the kernel module blocklist.

    Linux kernel module nfnetlink_queue module blocklist = nfnetlink_queue

Event History

Jul 26, 2022
CVE Published
09:00 AM
Jul 27, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software
Jul 28, 2022
Exploit Published
via GitHub·11:22 AM
Aug 4, 2022
Data Sourced
via Red Hat·10:47 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2022-36946?

CVE-2022-36946 has a high severity rating due to its potential to cause denial of service in the Linux Kernel.

2

How do I fix CVE-2022-36946?

To fix CVE-2022-36946, update to one of the patched versions listed, such as kernel-rt 0:4.18.0-425.3.1.rt7.213.el8 or kernel 0:5.14.0-162.6.1.el9_1.

3

Who is affected by CVE-2022-36946?

CVE-2022-36946 affects users of Linux Kernel versions prior to the patched versions listed in the advisory.

4

What is the impact of CVE-2022-36946?

The impact of CVE-2022-36946 can lead to system instability and denial of service due to improper packet handling.

5

Is CVE-2022-36946 a local or remote vulnerability?

CVE-2022-36946 is a local vulnerability that can be exploited by a local user to create a denial of service condition.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203