CVE-2022-37047: Buffer Overflow
The component tcprewrite in Tcpreplay v4.4.1 was discovered to contain a heap-based buffer overflow in getipv6next at common/get.c:713. NOTE: this is different from CVE-2022-27940.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/tcpreplayto a version that resolves this vulnerability.Fixed in 4.4.3-1Fixed in 4.5.1-1Fixed in 4.5.4-1 - Upgrade
Upgrade
debian/tcpreplayto a version that resolves this vulnerability.Fixed in 4.4.2-1
Event History
Frequently Asked Questions
What is the severity of CVE-2022-37047?
CVE-2022-37047 is classified as a high severity vulnerability due to its potential for exploitation via heap-based buffer overflow.
How do I fix CVE-2022-37047?
To fix CVE-2022-37047, update the Tcpreplay software to version 4.4.2 or later.
Which versions of Tcpreplay are affected by CVE-2022-37047?
Tcpreplay version 4.4.1 is the only affected version for CVE-2022-37047.
What components are impacted by CVE-2022-37047?
CVE-2022-37047 impacts the tcprewrite component of the Tcpreplay toolkit.
Is CVE-2022-37047 specific to any operating system?
CVE-2022-37047 primarily affects systems running Fedora 35, 36, and 37.