CVE-2022-37051: Medium severity Freedesktop poppler vulnerability

Published Aug 22, 2023
·
Updated

An issue was discovered in Poppler 22.07.0. There is a reachable abort which leads to denial of service because the main function in pdfunite.cc lacks a stream check before saving an embedded file.

Affected Software

11 affected componentsFixes available
ubuntu/poppler<22.08.0-2
22.08.0-2
ubuntu/poppler<0.62.0-2ubuntu2.14+
0.62.0-2ubuntu2.14+
ubuntu/poppler<0.86.1-0ubuntu1.4
0.86.1-0ubuntu1.4
ubuntu/poppler<22.02.0-2ubuntu0.3
22.02.0-2ubuntu0.3
ubuntu/poppler<0.41.0-0ubuntu1.16+
0.41.0-0ubuntu1.16+
Freedesktop poppler=22.07.0
Debian Debian Linux=10.0
debian/poppler<22.08.0-2
22.08.0-2
debian/poppler<22.08.0-2
22.08.0-2
debian/poppler<22.08.0-2
22.08.0-2
debian/poppler
22.12.0-2+deb12u222.12.0-2+deb12u325.03.0-5+deb13u425.03.0-5+deb13u326.07.0-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/poppler to a version that resolves this vulnerability.

    Fixed in 22.08.0-2
  2. Upgrade

    Upgrade ubuntu/poppler to a version that resolves this vulnerability.

    Fixed in 0.62.0-2ubuntu2.14+
  3. Upgrade

    Upgrade ubuntu/poppler to a version that resolves this vulnerability.

    Fixed in 0.86.1-0ubuntu1.4
  4. Upgrade

    Upgrade ubuntu/poppler to a version that resolves this vulnerability.

    Fixed in 22.02.0-2ubuntu0.3
  5. Upgrade

    Upgrade ubuntu/poppler to a version that resolves this vulnerability.

    Fixed in 0.41.0-0ubuntu1.16+
  6. Upgrade

    Upgrade debian/poppler to a version that resolves this vulnerability.

    Fixed in 22.12.0-2+deb12u2Fixed in 22.12.0-2+deb12u3Fixed in 25.03.0-5+deb13u4Fixed in 25.03.0-5+deb13u3Fixed in 26.07.0-3
  7. Upgrade

    Upgrade debian/poppler to a version that resolves this vulnerability.

    Fixed in 22.08.0-2

Event History

Aug 22, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·07:16 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·07:16 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-37051?

CVE-2022-37051 is a vulnerability in Poppler 22.07.0 that allows for denial of service due to a reachable abort in the main function of pdfunite.cc.

2

How severe is CVE-2022-37051?

CVE-2022-37051 has a severity of 6.5 (medium).

3

How does CVE-2022-37051 affect Poppler 22.07.0?

CVE-2022-37051 affects Poppler 22.07.0 by causing denial of service through a reachable abort in the main function of pdfunite.cc.

4

How can I fix the vulnerability CVE-2022-37051?

To fix CVE-2022-37051, it is recommended to update to a version of Poppler that includes the patch provided by the upstream vendor.

5

Where can I find more information about CVE-2022-37051?

More information about CVE-2022-37051 can be found in the references provided: [Reference 1](https://gitlab.freedesktop.org/poppler/poppler/-/commit/4631115647c1e4f0482ffe0491c2f38d2231337b) [Reference 2](https://gitlab.freedesktop.org/poppler/poppler/-/issues/1276)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203