CVE-2022-37451: High severity Exim Exim vulnerability
Published Aug 6, 2022
·Updated
Exim before 4.96 has an invalid free in pamconverse in auths/callpam.c because storefree is not used after storemalloc.
Affected Software
7 affected componentsFixes available
Exim Exim<4.96
Fedoraproject Fedora=35
Fedoraproject Fedora=36
debian/exim4<4.95-4
4.95-4
debian/exim4<4.95-4
4.95-4
debian/exim4<4.95-4
4.95-4
debian/exim4
4.96-15+deb12u104.98.2-1+deb13u44.98.2-1+deb13u54.100.1-4
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/exim4to a version that resolves this vulnerability.Fixed in 4.96-15+deb12u10Fixed in 4.98.2-1+deb13u4Fixed in 4.98.2-1+deb13u5Fixed in 4.100.1-4 - Upgrade
Upgrade
debian/exim4to a version that resolves this vulnerability.Fixed in 4.95-4
Event History
Aug 6, 2022
CVE Published
via MITRE·05:02 PM
Data Sourced
via MITRE·05:02 PM
Description
Data Sourced
via OSV·06:15 PM
DescriptionSeverityAffected Software
Frequently Asked Questions
1
What is the vulnerability ID of this vulnerability?
The vulnerability ID is CVE-2022-37451.
2
What is the severity of CVE-2022-37451?
The severity of CVE-2022-37451 is high with a severity value of 7.5.
3
What is the affected software for CVE-2022-37451?
The affected software for CVE-2022-37451 is Exim before 4.96 and Fedora versions 35 and 36.
4
How can I fix CVE-2022-37451?
You can fix CVE-2022-37451 by updating Exim to version 4.96 or applying the necessary updates for Fedora versions 35 and 36.
5
Where can I find more information about CWE-763?
You can find more information about CWE-763 at the Mitre website.