CVE-2022-3786: OpenSSL3 CVE-2022-3602 CVE-2022-3786 vulnerabilities

Published Oct 28, 2022
·
Updated

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed a malicious certificate or for an application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address in a certificate to overflow an arbitrary number of bytes containing the . character (decimal 46) on the stack. This buffer overflow could result in a crash (causing a denial of service).

In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects.

OpenSSL versions 3.0.0 to 3.0.6 are vulnerable to this issue.

All versions of the v18.x and v19.x releases lines.

Other sources

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed a malicious certificate or for an application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address in a certificate to overflow an arbitrary number of bytes containing the .' character (decimal 46) on the stack. This buffer overflow could result in a crash (causing a denial of service). In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects.

As per upstream report:

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow an arbitrary number of bytes containing the .' character (decimal 46) on the stack. This buffer overflow could result in a crash (causing a denial of service).

In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects.

OpenSSL versions 3.0.0 to 3.0.6 are vulnerable to this issue.

OpenSSL 3.0 users should upgrade to OpenSSL 3.0.7.

OpenSSL 1.1.1 and 1.0.2 are not affected by this issue.

— Red Hat

OpenSSL is vulnerable to a denial of service, caused by a stack based buffer overflow during X.509 certificate verification. By using a specially-crafted email address in a certificate, a remote attacker could exploit this vulnerability to cause a TLS client to crash, and results in a denial of service condition.

— IBM

Affected Software

34 affected componentsFixes available
IBM Cloud Pak for Business Automation<=V22.0.2 - V22.0.2-IF001
IBM Cloud Pak for Business Automation<=V21.0.3 - V21.0.3-IF017
IBM Cloud Pak for Business Automation<=V22.0.1 - V22.0.1-IF006 and later fixes V21.0.2 - V21.0.2-IF012 and later fixesV21.0.1 - V21.0.1-IF007 and later fixesV20.0.1 - V20.0.3 and later fixesV19.0.1 - V19.0.3 and later fixesV18.0.0 - V18.0.2 and later fixes
OpenSSL OpenSSL>=3.0.0<3.0.7
Fedoraproject Fedora=36
Fedoraproject Fedora=37
Nodejs Node.js>=18.0.0<18.11.0
Nodejs Node.js=18.12.0
Nodejs Node.js=19.0.0
Node.js Node.js>=18.0.0<18.12.1
18.12.1
Node.js Node.js>=19.0.0<19.0.1
19.0.1
debian/openssl
3.0.20-1~deb12u23.0.22-1~deb12u23.5.7-1~deb13u23.5.7-1~deb13u33.6.5-1
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/nodejs<18.12.1-r0
18.12.1-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl>=3.0.0<3.0.7-r0
3.0.7-r0
alpine/openssl3<3.0.7-r0
3.0.7-r0
alpine/openssl3<3.0.7-r0
3.0.7-r0
debian/openssl<3.0.7-1
3.0.7-1
debian/openssl<3.0.7-1
3.0.7-1
debian/openssl<3.0.7-1
3.0.7-1
redhat/openssl<3.0.7
3.0.7

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.12.1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 19.0.1
  3. Upgrade

    Upgrade debian/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.20-1~deb12u2Fixed in 3.0.22-1~deb12u2Fixed in 3.5.7-1~deb13u2Fixed in 3.5.7-1~deb13u3Fixed in 3.6.5-1
  4. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 18.12.1-r0
  5. Upgrade

    Upgrade alpine/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.7-r0
  6. Upgrade

    Upgrade alpine/openssl3 to a version that resolves this vulnerability.

    Fixed in 3.0.7-r0
  7. Upgrade

    Upgrade debian/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.7-1
  8. Upgrade

    Upgrade redhat/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.7
  9. Upgrade

    Upgrade OpenSSL to a version that resolves this vulnerability.

    Fixed in 3.0.7

Event History

Oct 28, 2022
Advisory Published
via FortiGuard·12:00 AM
Data Sourced
via FortiGuard·12:00 AM
DescriptionSeverityWeaknessAffected Software
Nov 1, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via Red Hat·01:31 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·06:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·06:15 PM
DescriptionSeverityAffected Software
Nov 3, 2022
Data Sourced
via Node.js·12:00 AM
DescriptionSeverity
Nov 4, 2022
Data Sourced
via Node.js·06:05 PM
Affected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID of this vulnerability?

The vulnerability ID is CVE-2022-3786.

2

What is the severity of CVE-2022-3786?

The severity of CVE-2022-3786 is high with a score of 7.5.

3

How does this vulnerability affect IBM Security Verify Privilege On-Premises?

IBM Security Verify Privilege On-Premises is affected by this vulnerability.

4

How can a remote attacker exploit this vulnerability?

A remote attacker can exploit this vulnerability by using a specially-crafted email address in a certificate.

5

What is the recommended action to mitigate this vulnerability?

Apply the necessary security patch or update provided by IBM to fix this vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203