CVE-2022-39047: Buffer Overflow
Published Aug 31, 2022
·Updated
Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.
Affected Software
6 affected componentsFixes available
Freeciv Freeciv<2.6.7
Freeciv Freeciv>=3.0.0<3.0.3
debian/freeciv<3.0.3-1
3.0.3-1
debian/freeciv<3.0.3-1
3.0.3-1
debian/freeciv<3.0.3-1
3.0.3-1
debian/freeciv
3.0.6-1+deb12u13.1.4+ds-2+deb13u13.2.6+ds-1
Remediation
Patch Available
Event History
Aug 31, 2022
CVE Published
via MITRE·05:15 AM
Data Sourced
via MITRE·05:15 AM
Description
Data Sourced
via OSV·06:15 AM
DescriptionSeverityAffected Software
Frequently Asked Questions
1
What is the severity of CVE-2022-39047?
CVE-2022-39047 has a high severity due to the potential for a remote code execution via a buffer overflow.
2
What versions of Freeciv are affected by CVE-2022-39047?
CVE-2022-39047 affects Freeciv versions prior to 2.6.7 and between 3.0.0 and 3.0.3.
3
How do I fix CVE-2022-39047?
To fix CVE-2022-39047, update Freeciv to version 2.6.7 or later, or to version 3.0.3 or later.
4
What is the nature of the vulnerability in CVE-2022-39047?
CVE-2022-39047 is a buffer overflow vulnerability occurring in the Modpack Installer's handling of modpack URLs.
5
Can CVE-2022-39047 be exploited remotely?
Yes, CVE-2022-39047 can be exploited remotely, allowing an attacker to execute arbitrary code on the target system.