CVE-2022-39189: Use After Free
A flaw was found in the x86 KVM subsystem in kvmstealtimesetpreempted in arch/x86/kvm/x86.c in the Linux kernel. Unprivileged guest users can compromise the guest kernel because TLB flush operations are mishandled in certain KVMVCPUPREEMPTED situations.
Other sources
An issue was discovered the x86 KVM subsystem in the Linux kernel before 5.18.17. Unprivileged guest users can compromise the guest kernel because TLB flush operations are mishandled in certain KVMVCPUPREEMPTED situations.
In multiple functions of many files, there is a possible out of bounds write due to a race condition. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.
— OSV
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-477.10.1.rt7.274.el8_8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-477.10.1.el8_8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:5.14.0-284.11.1.el9_2 - Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:5.14.0-284.11.1.rt14.296.el9_2 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.19 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.19.6-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
android/:linux_kernel:to a version that resolves this vulnerability.Fixed in :2023-02-05 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 5.18.17
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2022-39189?
CVE-2022-39189 has a high severity rating due to its potential to allow unprivileged guest users to compromise the guest kernel.
How do I fix CVE-2022-39189?
To fix CVE-2022-39189, update to the recommended kernel versions specified in the remediation section.
What systems are affected by CVE-2022-39189?
CVE-2022-39189 impacts various versions of the Linux kernel and specific NetApp HCI baseboard management controllers.
Can CVE-2022-39189 be exploited remotely?
CVE-2022-39189 does not appear to be a remotely exploitable vulnerability, as it involves unprivileged access within guest environments.
Is there a workaround for CVE-2022-39189?
Currently, there are no known workarounds for CVE-2022-39189 other than applying the appropriate updates.