CVE-2022-39331: Cross-site Scripting (XSS) in Nexcloud Desktop Client
Nexcloud desktop is the Desktop sync client for Nextcloud. An attacker can inject arbitrary HyperText Markup Language into the Desktop Client application in the notifications. It is recommended that the Nextcloud Desktop client is upgraded to 3.6.1. There are no known workarounds for this issue.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/nextcloud-desktopto a version that resolves this vulnerability.Fixed in 3.7.3-1+deb12u2Fixed in 3.16.7-1~deb13u1Fixed in 35.0.0-1 - Upgrade
Upgrade
debian/nextcloud-desktopto a version that resolves this vulnerability.Fixed in 3.6.1-1 - Upgrade
Upgrade
Nextcloud Desktop Clientto a version that resolves this vulnerability.Fixed in 3.6.1
Event History
Frequently Asked Questions
What is CVE-2022-39331?
CVE-2022-39331 is a vulnerability in the Nextcloud Desktop sync client that allows an attacker to inject arbitrary HTML into the application's notifications.
What is the severity of CVE-2022-39331?
CVE-2022-39331 has a severity rating of 5.4, which is considered medium.
How can I fix CVE-2022-39331?
To fix CVE-2022-39331, it is recommended that you upgrade your Nextcloud Desktop client to version 3.6.1 or higher.
Are there any workarounds for CVE-2022-39331?
There are no known workarounds for CVE-2022-39331.
Where can I find more information about CVE-2022-39331?
You can find more information about CVE-2022-39331 in the references provided: [GitHub Pull Request](https://github.com/nextcloud/desktop/pull/4944), [Nextcloud Security Advisories](https://github.com/nextcloud/security-advisories/security/advisories/GHSA-c3xh-q694-6rc5), [HackerOne Report](https://hackerone.com/reports/1668028).