CVE-2022-41218: Use After Free
A flaw in the Linux Kernel dvb-core sub system (DVB API used by Digital TV devices) found. The result of race condition inside drivers/media/dvb-core/dmxdev.c is use after free. For triggering attack the local user have to physically remove USB device (like DVB demultiplexer device), and both run some malicious code.
Reference: https://www.openwall.com/lists/oss-security/2022/09/23/4
Other sources
A use-after-free flaw was found in the Linux kernel’s dvb-core subsystem (DVB API used by Digital TV devices) in how a user physically removed a USB device (such as a DVB demultiplexer device) while running malicious code. This flaw allows a local user to crash or potentially escalate their privileges on the system.
In drivers/media/dvb-core/dmxdev.c in the Linux kernel through 5.19.10, there is a use-after-free caused by refcount races, affecting dvbdemuxopen and dvbdmxdevrelease.
— Ubuntu
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-477.10.1.rt7.274.el8_8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-477.10.1.el8_8 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.4-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Configuration
Blacklist the dvb-core kernel module to prevent it from being loaded automatically.
Linux kernel module dvb-core module loading = blacklisted/disabled
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2022-41218?
CVE-2022-41218 has a severity rating of high due to the potential for a local user to exploit a race condition leading to a use after free vulnerability.
How do I fix CVE-2022-41218?
To fix CVE-2022-41218, update your Linux kernel to version 5.10.223-1, 5.10.226-1, 6.1.119-1, 6.1.123-1, 6.12.11-1, or 6.12.12-1 or equivalent Red Hat packages.
Who is affected by CVE-2022-41218?
CVE-2022-41218 affects users of the Linux Kernel, particularly those utilizing the DVB API in Digital TV devices.
What causes the CVE-2022-41218 vulnerability?
The CVE-2022-41218 vulnerability is caused by a race condition inside the dvb-core subsystem leading to a use after free condition when a USB device is physically removed.
Can CVE-2022-41218 be exploited remotely?
CVE-2022-41218 cannot be exploited remotely as it requires local access to the system to trigger the vulnerability.