CVE-2022-41674: Buffer Overflow

Published Oct 13, 2022
·
Updated

A buffer overflow flaw was found in the u8 overflow in cfg80211updatenotlistednontrans() in net/wireless/scan.c in the Linux kernel’s wifi subcomponent. This flaw allows an attacker to crash the system or leak internal kernel information.

Other sources

An issue was discovered in the Linux kernel before 5.19.16. Attackers able to inject WLAN frames could cause a buffer overflow in the ieee80211bssinfoupdate function in net/mac80211/scan.c.

— Ubuntu

In cfg80211updatenotlistednontrans of scan.c, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is not needed for exploitation.

— OSV

In the copy code of the elements, we do the following calculation to reach the end of the MBSSID element:

/ copy the IEs after MBSSID / cpylen = mbssid[1] + 2;

This looks fine, however, cpylen is a u8, the same as mbssid[1], so the addition of two can overflow. In this case the subsequent memcpy() will overflow the allocated buffer, since it copies 256 bytes too much due to the way the allocation and memcpy() sizes are calculated.

— Red Hat

Affected Software

29 affected componentsFixes available
redhat/kernel-rt<0:4.18.0-477.10.1.rt7.274.el8_8
0:4.18.0-477.10.1.rt7.274.el8_8
redhat/kernel<0:4.18.0-477.10.1.el8_8
0:4.18.0-477.10.1.el8_8
redhat/kernel<0:5.14.0-284.11.1.el9_2
0:5.14.0-284.11.1.el9_2
redhat/kernel-rt<0:5.14.0-284.11.1.rt14.296.el9_2
0:5.14.0-284.11.1.rt14.296.el9_2
Linux Linux kernel>=5.1<5.4.218
Linux Linux kernel>=5.5<5.10.148
Linux Linux kernel>=5.11<5.15.74
Linux Linux kernel>=5.16<5.19.16
Linux Linux kernel>=6.0<6.0.2
Fedoraproject Fedora=35
Fedoraproject Fedora=36
Fedoraproject Fedora=37
Debian Debian Linux=10.0
Debian Debian Linux=11.0
Google Android
android/:linux_kernel:>=:0<:2023-01-05
:2023-01-05
debian/linux<6.0.2-1
6.0.2-1
debian/linux<6.0.2-1
6.0.2-1
debian/linux<6.0.2-1
6.0.2-1
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
alpine/linux-lts<5.15.74-r0
5.15.74-r0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-477.10.1.rt7.274.el8_8
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-477.10.1.el8_8
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-284.11.1.el9_2
  4. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-284.11.1.rt14.296.el9_2
  5. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.0.2-1
  6. Upgrade

    Upgrade alpine/linux-lts to a version that resolves this vulnerability.

    Fixed in 5.15.74-r0
  7. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  8. Upgrade

    Upgrade android/:linux_kernel: to a version that resolves this vulnerability.

    Fixed in :2023-01-05
  9. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Fixed in 5.19.16

Event History

Oct 13, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via Red Hat·09:58 AM
DescriptionSeverityAffected Software
Oct 14, 2022
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via NVD·12:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·12:15 AM
DescriptionSeverityAffected Software
Jan 1, 2023
Advisory Published
via OSV·12:00 AM
Jan 3, 2023
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2022-41674?

CVE-2022-41674 is classified as a high-severity vulnerability due to its potential to cause system crashes and internal data leakage.

2

How do I fix CVE-2022-41674?

To fix CVE-2022-41674, update to kernel versions 5.10.223-1, 5.10.226-1, 6.1.123-1, or later remedied versions as specified by your distribution.

3

Which systems are affected by CVE-2022-41674?

CVE-2022-41674 affects multiple Linux kernel versions and distributions, including certain versions of Red Hat, Debian, and Fedora.

4

What are the possible impacts of exploiting CVE-2022-41674?

Exploiting CVE-2022-41674 can lead to a denial of service through system crashes and unintended exposure of sensitive kernel information.

5

Has CVE-2022-41674 been disclosed publicly?

Yes, CVE-2022-41674 has been publicly disclosed and is documented on various security platforms and repositories.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203