CVE-2022-41859: Infoleak
In freeradius, the EAP-PWD function computepasswordelement() leaks information about the password which allows an attacker to substantially reduce the size of an offline dictionary attack.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/freeradiusto a version that resolves this vulnerability.Fixed in 3.2.1+dfsg-4+deb12u1Fixed in 3.2.7+dfsg-1+deb13u2Fixed in 3.2.10+dfsg-2 - Upgrade
Upgrade
alpine/freeradiusto a version that resolves this vulnerability.Fixed in 3.0.26-r0 - Upgrade
Upgrade
debian/freeradiusto a version that resolves this vulnerability.Fixed in 3.2.0+dfsg-1
Event History
Frequently Asked Questions
What is the severity of CVE-2022-41859?
CVE-2022-41859 is classified as a medium severity vulnerability.
How do I fix CVE-2022-41859?
To fix CVE-2022-41859, upgrade FreeRADIUS to version 3.0.0 or later.
What component is affected by CVE-2022-41859?
CVE-2022-41859 affects the EAP-PWD function in FreeRADIUS.
What type of attack does CVE-2022-41859 facilitate?
CVE-2022-41859 allows attackers to reduce the time needed for an offline dictionary attack.
What information is leaked due to CVE-2022-41859?
CVE-2022-41859 leaks information about user passwords.