CVE-2022-41861: Input Validation
A flaw was found in freeradius. A malicious RADIUS client or home server can send a malformed abinary attribute which can cause the server to crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/freeradiusto a version that resolves this vulnerability.Fixed in 3.2.1+dfsg-4+deb12u1Fixed in 3.2.7+dfsg-1+deb13u2Fixed in 3.2.10+dfsg-2 - Upgrade
Upgrade
alpine/freeradiusto a version that resolves this vulnerability.Fixed in 3.0.26-r0 - Upgrade
Upgrade
debian/freeradiusto a version that resolves this vulnerability.Fixed in 3.2.0+dfsg-1
Event History
Frequently Asked Questions
What is the severity of CVE-2022-41861?
CVE-2022-41861 has been classified as a critical vulnerability due to its potential to crash the FreeRADIUS server.
How do I fix CVE-2022-41861?
To fix CVE-2022-41861, upgrade FreeRADIUS to version 3.0.26 or later.
What versions of FreeRADIUS are affected by CVE-2022-41861?
FreeRADIUS versions up to and including 3.0.25 are affected by CVE-2022-41861.
What impact does CVE-2022-41861 have on my system?
CVE-2022-41861 allows a malicious client to send a malformed attribute, potentially causing the FreeRADIUS server to crash.
Is there a patch available for CVE-2022-41861?
Yes, a patch is included in FreeRADIUS version 3.0.26 and later to address CVE-2022-41861.