CVE-2022-42258: Integer Overflow

Published Dec 30, 2022
·
Updated

NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where an integer overflow may lead to denial of service, data tampering, or information disclosure.

Affected Software

37 affected componentsFixes available
Nvidia Gpu Display Driver Linux>=390<390.157
Nvidia Gpu Display Driver Linux>=470<470.161.03
Nvidia Gpu Display Driver Linux>=510<510.108.03
Nvidia Gpu Display Driver Linux>=515<515.86.01
Nvidia Gpu Display Driver Linux>=525<525.60.11
Nvidia Geforce
Nvidia Nvs
Nvidia Quadro
Nvidia Rtx
Nvidia Gpu Display Driver Linux>=450<450.216.04
Nvidia Tesla
Nvidia Cloud Gaming<525.60.12
Citrix Hypervisor
redhat Enterprise Linux Kernel-based Virtual Machine
Nvidia Virtual GPU<11.11
Nvidia Virtual GPU>=12.0<13.6
Nvidia Virtual GPU>=14.0<14.4
Linux Linux kernel
VMware vSphere
Nvidia Cloud Gaming<525.60.11
Debian Debian Linux=10.0
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers-tesla<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers-tesla-470<470.161.03-1
470.161.03-1
debian/nvidia-open-gpu-kernel-modules<515.86.01-1
515.86.01-1
debian/nvidia-open-gpu-kernel-modules<515.86.01-1
515.86.01-1
debian/nvidia-graphics-drivers
535.261.03-1535.309.01-0+deb12u1550.163.01-2550.163.01-5.1550.163.01-6
debian/nvidia-graphics-drivers-legacy-340xx<=340.108-28
debian/nvidia-graphics-drivers-legacy-390xx
390.157-16
debian/nvidia-graphics-drivers-tesla
525.147.05-15~deb12u1525.147.05-19
debian/nvidia-graphics-drivers-tesla-418<=418.226.00-22
debian/nvidia-graphics-drivers-tesla-450
450.248.02-14
debian/nvidia-graphics-drivers-tesla-460
460.106.00-24
debian/nvidia-graphics-drivers-tesla-470
470.256.02-1~deb12u1470.256.02-10
debian/nvidia-open-gpu-kernel-modules
535.261.03-1550.163.01-2550.163.01-4.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6
  2. Upgrade

    Upgrade debian/nvidia-graphics-drivers-legacy-390xx to a version that resolves this vulnerability.

    Fixed in 390.157-16
  3. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla to a version that resolves this vulnerability.

    Fixed in 525.147.05-15~deb12u1Fixed in 525.147.05-19
  4. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-450 to a version that resolves this vulnerability.

    Fixed in 450.248.02-14
  5. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-460 to a version that resolves this vulnerability.

    Fixed in 460.106.00-24
  6. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10
  7. Upgrade

    Upgrade debian/nvidia-open-gpu-kernel-modules to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 550.163.01-2Fixed in 550.163.01-4.1
  8. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 510.108.03-1
  9. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla to a version that resolves this vulnerability.

    Fixed in 510.108.03-1
  10. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.161.03-1
  11. Upgrade

    Upgrade debian/nvidia-open-gpu-kernel-modules to a version that resolves this vulnerability.

    Fixed in 515.86.01-1

Event History

Dec 30, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·11:15 PM
DescriptionSeverityAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID for this NVIDIA GPU Display Driver vulnerability?

The vulnerability ID for this NVIDIA GPU Display Driver vulnerability is CVE-2022-42258.

2

What is the severity of CVE-2022-42258?

The severity of CVE-2022-42258 is high with a CVSS score of 7.3.

3

Which software versions are affected by the NVIDIA GPU Display Driver vulnerability?

The NVIDIA GPU Display Driver vulnerability affects versions 390 to 525.60.11 of the NVIDIA GPU Display Driver for Linux.

4

What are the potential impacts of CVE-2022-42258?

The potential impacts of CVE-2022-42258 include denial of service, data tampering, and information disclosure.

5

Where can I find more information about CVE-2022-42258?

You can find more information about CVE-2022-42258 at the following references: [link1](https://lists.debian.org/debian-lts-announce/2023/05/msg00010.html), [link2](https://nvidia.custhelp.com/app/answers/detail/a_id/5415), [link3](https://security.gentoo.org/glsa/202310-02).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203