CVE-2022-42260: High severity Nvidia Virtual GPU vulnerability
NVIDIA vGPU Display Driver for Linux guest contains a vulnerability in a D-Bus configuration file, where an unauthorized user in the guest VM can impact protected D-Bus endpoints, which may lead to code execution, denial of service, escalation of privileges, information disclosure, or data tampering.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-teslato a version that resolves this vulnerability.Fixed in 525.147.05-15~deb12u1Fixed in 525.147.05-19 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-450to a version that resolves this vulnerability.Fixed in 450.248.02-14 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-460to a version that resolves this vulnerability.Fixed in 460.106.00-24 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-470to a version that resolves this vulnerability.Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10 - Upgrade
Upgrade
debian/nvidia-graphics-driversto a version that resolves this vulnerability.Fixed in 510.108.03-1 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-teslato a version that resolves this vulnerability.Fixed in 510.108.03-1 - Upgrade
Upgrade
debian/nvidia-graphics-drivers-tesla-470to a version that resolves this vulnerability.Fixed in 470.161.03-1
Event History
Frequently Asked Questions
What is CVE-2022-42260?
CVE-2022-42260 is a vulnerability in the NVIDIA vGPU Display Driver for Linux guest, where an unauthorized user in the guest VM can impact protected D-Bus endpoints, leading to various potential consequences.
What is the severity of CVE-2022-42260?
The severity of CVE-2022-42260 is high, with a CVSS score of 7.8.
How does CVE-2022-42260 affect NVIDIA Virtual GPU?
NVIDIA Virtual GPU versions up to and including 11.11 are affected by CVE-2022-42260.
How can CVE-2022-42260 be fixed?
To fix CVE-2022-42260, users should update their NVIDIA vGPU Display Driver for Linux guest to a non-vulnerable version.
Are Citrix Hypervisor and Linux kernel vulnerable to CVE-2022-42260?
No, Citrix Hypervisor and Linux kernel are not vulnerable to CVE-2022-42260.