CVE-2022-42264: Buffer Overflow

Published Dec 30, 2022
·
Updated

NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer, where an unprivileged regular user can cause the use of an out-of-range pointer offset, which may lead to data tampering, data loss, information disclosure, or denial of service.

Affected Software

32 affected componentsFixes available
Nvidia Virtual GPU<11.11
Nvidia Virtual GPU>=12.0<13.6
Nvidia Virtual GPU>=14.0<14.4
Citrix Hypervisor
Linux Linux kernel
redhat Enterprise Linux Kernel-based Virtual Machine
VMware vSphere
Nvidia Cloud Gaming<525.60.11
Nvidia Cloud Gaming<525.60.12
Nvidia Gpu Display Driver Linux>=470<470.161.03
Nvidia Gpu Display Driver Linux>=510<510.108.03
Nvidia Gpu Display Driver Linux>=515<515.86.01
Nvidia Geforce
Nvidia Nvs
Nvidia Quadro
Nvidia Rtx
Nvidia Gpu Display Driver Linux>=450<450.216.04
Nvidia Tesla
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers-tesla<510.108.03-1
510.108.03-1
debian/nvidia-graphics-drivers-tesla-470<470.161.03-1
470.161.03-1
debian/nvidia-open-gpu-kernel-modules<515.86.01-1
515.86.01-1
debian/nvidia-open-gpu-kernel-modules<515.86.01-1
515.86.01-1
debian/nvidia-graphics-drivers
535.261.03-1535.309.01-0+deb12u1550.163.01-2550.163.01-5.1550.163.01-6
debian/nvidia-graphics-drivers-tesla
525.147.05-15~deb12u1525.147.05-19
debian/nvidia-graphics-drivers-tesla-418<=418.226.00-22
debian/nvidia-graphics-drivers-tesla-450
450.248.02-14
debian/nvidia-graphics-drivers-tesla-460
460.106.00-24
debian/nvidia-graphics-drivers-tesla-470
470.256.02-1~deb12u1470.256.02-10
debian/nvidia-open-gpu-kernel-modules
535.261.03-1550.163.01-2550.163.01-4.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6
  2. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla to a version that resolves this vulnerability.

    Fixed in 525.147.05-15~deb12u1Fixed in 525.147.05-19
  3. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-450 to a version that resolves this vulnerability.

    Fixed in 450.248.02-14
  4. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-460 to a version that resolves this vulnerability.

    Fixed in 460.106.00-24
  5. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10
  6. Upgrade

    Upgrade debian/nvidia-open-gpu-kernel-modules to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 550.163.01-2Fixed in 550.163.01-4.1
  7. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 510.108.03-1
  8. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla to a version that resolves this vulnerability.

    Fixed in 510.108.03-1
  9. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.161.03-1
  10. Upgrade

    Upgrade debian/nvidia-open-gpu-kernel-modules to a version that resolves this vulnerability.

    Fixed in 515.86.01-1

Event History

Dec 30, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·11:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2022-42264?

CVE-2022-42264 is a vulnerability in the NVIDIA GPU Display Driver for Linux that allows an unprivileged regular user to cause data tampering, data loss, information disclosure, or denial of service.

2

How does CVE-2022-42264 affect NVIDIA Virtual GPU?

CVE-2022-42264 affects NVIDIA Virtual GPU versions up to and exclusive to 11.11.

3

How does CVE-2022-42264 affect Citrix Hypervisor?

CVE-2022-42264 does not affect Citrix Hypervisor.

4

What is the severity of CVE-2022-42264?

The severity of CVE-2022-42264 is high with a score of 7.8.

5

How do I fix CVE-2022-42264?

To fix CVE-2022-42264, update to a version of the NVIDIA GPU Display Driver for Linux that is not vulnerable.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203