CVE-2022-43497: XSS
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.1.9+dfsg1-0+deb12u1Fixed in 6.8.7+dfsg1-0+deb13u1Fixed in 6.8.12+dfsg1-0+deb13u1Fixed in 7.1.4+dfsg1-1 - Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.0.3+dfsg1-1 - Upgrade
Upgrade
WordPressto a version that resolves this vulnerability.Fixed in 6.0.3
Event History
Frequently Asked Questions
What is the vulnerability ID for this cross-site scripting vulnerability in WordPress?
The vulnerability ID is CVE-2022-43497.
What is the severity of CVE-2022-43497?
The severity of CVE-2022-43497 is medium.
What is the affected software for CVE-2022-43497?
The affected software is WordPress versions prior to 6.0.3.
How can a remote unauthenticated attacker exploit CVE-2022-43497?
A remote unauthenticated attacker can exploit CVE-2022-43497 by injecting an arbitrary script.
How can CVE-2022-43497 be fixed?
CVE-2022-43497 can be fixed by upgrading WordPress to version 6.0.3 or applying the provided patched releases for all versions since 3.7.