CVE-2022-43504: Medium severity WordPress WordPress vulnerability
Improper authentication vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to obtain the email address of the user who posted a blog using the WordPress Post by Email Feature. The developer also provides new patched releases for all versions since 3.7.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.1.9+dfsg1-0+deb12u1Fixed in 6.8.7+dfsg1-0+deb13u1Fixed in 6.8.12+dfsg1-0+deb13u1Fixed in 7.1.4+dfsg1-1 - Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.0.3+dfsg1-1 - Upgrade
Upgrade
WordPressto a version that resolves this vulnerability.Fixed in 6.0.3
Event History
Frequently Asked Questions
What is CVE-2022-43504?
CVE-2022-43504 is an improper authentication vulnerability in WordPress versions prior to 6.0.3.
How can a remote unauthenticated attacker exploit CVE-2022-43504?
A remote unauthenticated attacker can exploit CVE-2022-43504 to obtain the email address of the user who posted a blog using the WordPress Post by Email Feature.
Which versions of WordPress are affected by CVE-2022-43504?
WordPress versions prior to 6.0.3 are affected by CVE-2022-43504.
What is the severity of CVE-2022-43504?
CVE-2022-43504 has a severity rating of 5.3 (medium).
How do I fix CVE-2022-43504?
To fix CVE-2022-43504, you should update your WordPress installation to version 6.0.3 or later.