CVE-2022-43548: DNS rebinding in --inspect via invalid octal IP address
A flaw was found in NodeJS. The issue occurs in the Node.js rebinding protector for --inspect that still allows invalid IP addresses, specifically, the octal format. This flaw allows an attacker to perform DNS rebinding and execute arbitrary code.
Other sources
A OS Command Injection vulnerability exists in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19.0.1 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.The fix for this issue in https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-32212 was incomplete and this new CVE is to complete the fix.
Hi upstream just released nodejs 14.21.1 to fix CVE-2022-43548 https://github.com/nodejs/node/releases/tag/v14.21.1 https://nodejs.org/en/blog/release/v18.12.1/ https://nodejs.org/en/blog/release/v16.18.1/
— Red Hat
The Node.js rebinding protector for --inspect still allows invalid IP address, specifically, the octal format.
— Node.Js
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/nodejsto a version that resolves this vulnerability.Fixed in 18-9010020221118120946.rhel9 - Upgrade
Upgrade
redhat/nodejsto a version that resolves this vulnerability.Fixed in 1:16.18.1-3.el9_1 - Upgrade
Upgrade
redhat/rh-nodejs14-nodejsto a version that resolves this vulnerability.Fixed in 0:14.21.1-3.el7 - Upgrade
Upgrade
redhat/rh-nodejs14-nodejs-nodemonto a version that resolves this vulnerability.Fixed in 0:2.0.20-2.el7 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 14.21.1Fixed in 16.18.1Fixed in 18.12.1Fixed in 19.0.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 14.21.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 16.18.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 18.12.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 19.0.1 - Upgrade
Upgrade
debian/nodejsto a version that resolves this vulnerability.Fixed in 18.20.4+dfsg-1~deb12u2Fixed in 18.20.4+dfsg-1~deb12u3Fixed in 20.19.2+dfsg-1+deb13u2Fixed in 20.19.2+dfsg-1+deb13u3Fixed in 24.21.0+dfsg+~cs24.13.4-1Fixed in 24.22.2+dfsg+~cs24.19.2-1 - Upgrade
Upgrade
alpine/nodejsto a version that resolves this vulnerability.Fixed in 18.12.1-r0 - Upgrade
Upgrade
debian/nodejsto a version that resolves this vulnerability.Fixed in 18.12.1+dfsg-1 - Upgrade
Upgrade
nodejs/nodeto a version that resolves this vulnerability.Fixed in 14.21.1 - Upgrade
Upgrade
nodejs/nodeto a version that resolves this vulnerability.Fixed in 16.18.1 - Upgrade
Upgrade
nodejs/nodeto a version that resolves this vulnerability.Fixed in 18.12.1 - Upgrade
Upgrade
nodejs/nodeto a version that resolves this vulnerability.Fixed in 19.0.1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is CVE-2022-43548?
CVE-2022-43548 is a OS Command Injection vulnerability in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19.0.1 that allows for rebinding attacks.
What is the severity of CVE-2022-43548?
The severity of CVE-2022-43548 is high with a CVSS score of 7.5.
How does CVE-2022-43548 occur?
CVE-2022-43548 occurs due to an insufficient IsAllowedHost check in Node.js that can be bypassed, allowing for rebinding attacks.
Which versions of Node.js are affected by CVE-2022-43548?
Node.js versions <14.21.1, <16.18.1, <18.12.1, <19.0.1 are affected by CVE-2022-43548.
How can CVE-2022-43548 be fixed?
To fix CVE-2022-43548, it is recommended to upgrade to Node.js versions 14.21.1, 16.18.1, 18.12.1, or 19.0.1.