CWE
416
Advisory Published
Updated

CVE-2022-4382: Use After Free

First published: Tue Jan 10 2023(Updated: )

A use-after-free flaw caused by a race among the superblock operations in the gadgetfs Linux driver was found. It could be triggered by yanking out a device that is running the gadgetfs side.

Credit: secalert@redhat.com secalert@redhat.com

Affected SoftwareAffected VersionHow to fix
Linux Linux kernel
ubuntu/linux<5.4.0-146.163
5.4.0-146.163
ubuntu/linux<5.15.0-69.76
5.15.0-69.76
ubuntu/linux<5.19.0-38.39
5.19.0-38.39
ubuntu/linux<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws<5.4.0-1099.107
5.4.0-1099.107
ubuntu/linux-aws<5.15.0-1033.37
5.15.0-1033.37
ubuntu/linux-aws<5.19.0-1022.23
5.19.0-1022.23
ubuntu/linux-aws<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws-5.0<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws-5.15<5.15.0-1033.37~20.04.1
5.15.0-1033.37~20.04.1
ubuntu/linux-aws-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws-5.4<5.4.0-1099.107~18.04.1
5.4.0-1099.107~18.04.1
ubuntu/linux-aws-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws-fips<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-aws-hwe<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure<5.4.0-1105.111
5.4.0-1105.111
ubuntu/linux-azure<5.15.0-1035.42
5.15.0-1035.42
ubuntu/linux-azure<5.19.0-1022.23
5.19.0-1022.23
ubuntu/linux-azure<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-4.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-5.15<5.15.0-1035.42~20.04.1
5.15.0-1035.42~20.04.1
ubuntu/linux-azure-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-5.19<5.19.0-1022.23~22.04.1
5.19.0-1022.23~22.04.1
ubuntu/linux-azure-5.4<5.4.0-1105.111~18.04.1
5.4.0-1105.111~18.04.1
ubuntu/linux-azure-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-edge<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-fde<5.4.0-1105.111
5.4.0-1105.111
ubuntu/linux-azure-fde<5.15.0-1035.42.1
5.15.0-1035.42.1
ubuntu/linux-azure-fde<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-fde-5.15<5.15.0-1035.42~20.04.1.1
5.15.0-1035.42~20.04.1.1
ubuntu/linux-azure-fde-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-azure-fips<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-bluefield<5.4.0-1060.66
5.4.0-1060.66
ubuntu/linux-bluefield<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-dell300x<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-fips<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gcp<5.4.0-1102.111
5.4.0-1102.111
ubuntu/linux-gcp<5.15.0-1031.38
5.15.0-1031.38
ubuntu/linux-gcp<5.19.0-1019.21
5.19.0-1019.21
ubuntu/linux-gcp<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gcp-4.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gcp-5.15<5.15.0-1031.38~20.04.1
5.15.0-1031.38~20.04.1
ubuntu/linux-gcp-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gcp-5.4<5.4.0-1102.111~18.04.2
5.4.0-1102.111~18.04.2
ubuntu/linux-gcp-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gcp-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gcp-fips<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gke<5.4.0-1096.103
5.4.0-1096.103
ubuntu/linux-gke<5.15.0-1030.35
5.15.0-1030.35
ubuntu/linux-gke<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gke-4.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gke-5.0<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gke-5.15<5.15.0-1029.34~20.04.1
5.15.0-1029.34~20.04.1
ubuntu/linux-gke-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gke-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gkeop<5.4.0-1066.70
5.4.0-1066.70
ubuntu/linux-gkeop<5.15.0-1017.22
5.15.0-1017.22
ubuntu/linux-gkeop<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gkeop-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-gkeop-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-hwe<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-hwe-5.15<5.15.0-69.76~20.04.1
5.15.0-69.76~20.04.1
ubuntu/linux-hwe-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-hwe-5.19<5.19.0-38.39~22.04.1
5.19.0-38.39~22.04.1
ubuntu/linux-hwe-5.4<5.4.0-146.163~18.04.1
5.4.0-146.163~18.04.1
ubuntu/linux-hwe-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-hwe-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-hwe-edge<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-ibm<5.4.0-1046.51
5.4.0-1046.51
ubuntu/linux-ibm<5.15.0-1027.30
5.15.0-1027.30
ubuntu/linux-ibm<5.19.0-1019.21
5.19.0-1019.21
ubuntu/linux-ibm<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-ibm-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-ibm-5.4<5.4.0-1046.51~18.04.1
5.4.0-1046.51~18.04.1
ubuntu/linux-ibm-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-intel<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-intel-5.13<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-intel-iotg<5.15.0-1027.32
5.15.0-1027.32
ubuntu/linux-intel-iotg<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-intel-iotg-5.15<5.15.0-1027.32~20.04.1
5.15.0-1027.32~20.04.1
ubuntu/linux-intel-iotg-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-iot<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-kvm<5.4.0-1088.94
5.4.0-1088.94
ubuntu/linux-kvm<5.15.0-1030.35
5.15.0-1030.35
ubuntu/linux-kvm<5.19.0-1020.21
5.19.0-1020.21
ubuntu/linux-kvm<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-laptop<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-lowlatency<5.15.0-69.76
5.15.0-69.76
ubuntu/linux-lowlatency<5.19.0-1021.22
5.19.0-1021.22
ubuntu/linux-lowlatency<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-lowlatency-hwe-5.15<5.15.0-69.76~20.04.1
5.15.0-69.76~20.04.1
ubuntu/linux-lowlatency-hwe-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-lowlatency-hwe-5.19<5.19.0-1021.22~22.04.1
5.19.0-1021.22~22.04.1
ubuntu/linux-lowlatency-hwe-5.19<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-lowlatency-hwe-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-lts-xenial<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-nvidia<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-nvidia-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-5.10<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-5.14<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-5.17<5.17.0-1030.31
5.17.0-1030.31
ubuntu/linux-oem-5.17<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-5.6<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-6.0<6.0.0-1014.14
6.0.0-1014.14
ubuntu/linux-oem-6.0<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-6.1<6.1.0-1008.8
6.1.0-1008.8
ubuntu/linux-oem-6.1<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-6.8<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oem-osp1<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oracle<5.4.0-1098.107
5.4.0-1098.107
ubuntu/linux-oracle<5.15.0-1032.38
5.15.0-1032.38
ubuntu/linux-oracle<5.19.0-1019.22
5.19.0-1019.22
ubuntu/linux-oracle<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oracle-5.0<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oracle-5.13<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oracle-5.15<5.15.0-1032.38~20.04.1
5.15.0-1032.38~20.04.1
ubuntu/linux-oracle-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oracle-5.4<5.4.0-1098.107~18.04.1
5.4.0-1098.107~18.04.1
ubuntu/linux-oracle-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-oracle-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-raspi<5.4.0-1082.93
5.4.0-1082.93
ubuntu/linux-raspi<5.15.0-1026.28
5.15.0-1026.28
ubuntu/linux-raspi<5.19.0-1015.22
5.19.0-1015.22
ubuntu/linux-raspi<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-raspi-5.4<5.4.0-1082.93~18.04.1
5.4.0-1082.93~18.04.1
ubuntu/linux-raspi-5.4<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-raspi2<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-riscv<5.19.0-1015.16
5.19.0-1015.16
ubuntu/linux-riscv<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-riscv-5.15<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-riscv-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-snapdragon<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-starfive<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-starfive-6.5<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
ubuntu/linux-xilinx-zynqmp<5.4.0-1023.27
5.4.0-1023.27
ubuntu/linux-xilinx-zynqmp<6.2~<5.4.230<5.15.90
6.2~
5.4.230
5.15.90
debian/linux
5.10.218-1
5.10.221-1
6.1.94-1
6.1.99-1
6.9.8-1
6.9.9-1

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203