CVE-2022-44572: High severity Rack Project Rack Ruby vulnerability
A denial of service vulnerability in the multipart parsing component of Rack fixed in 2.0.9.2, 2.1.4.2, 2.2.4.1 and 3.0.0.1 could allow an attacker tocraft input that can cause RFC2183 multipart boundary parsing in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted.
Other sources
Carefully crafted input can cause RFC2183 multipart boundary parsing in Rackto take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted.
— Red Hat
There is a denial of service vulnerability in the multipart parsing component of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-44572.
Versions Affected: >= 2.0.0 Not affected: None. Fixed Versions: 2.0.9.2, 2.1.4.2, 2.2.6.1, 3.0.0.1 Impact
Carefully crafted input can cause RFC2183 multipart boundary parsing in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted. Releases
The fixed releases are available at the normal locations. Workarounds
There are no feasible workarounds for this issue. Patches
To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset.
2-0-Forbid-control-characters-in-attributes.patch - Patch for 2.0 series 2-1-Forbid-control-characters-in-attributes.patch - Patch for 2.1 series 2-2-Forbid-control-characters-in-attributes.patch - Patch for 2.2 series 3-0-Forbid-control-characters-in-attributes.patch - Patch for 3.0 series
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
rubygems/rackto a version that resolves this vulnerability.Fixed in 3.0.4.1 - Upgrade
Upgrade
rubygems/rackto a version that resolves this vulnerability.Fixed in 2.2.6.1 - Upgrade
Upgrade
rubygems/rackto a version that resolves this vulnerability.Fixed in 2.1.4.2 - Upgrade
Upgrade
rubygems/rackto a version that resolves this vulnerability.Fixed in 2.0.9.2 - Upgrade
Upgrade
redhat/rubygem-rackto a version that resolves this vulnerability.Fixed in 2.0.9.2 - Upgrade
Upgrade
redhat/rubygem-rackto a version that resolves this vulnerability.Fixed in 2.1.4.2 - Upgrade
Upgrade
redhat/rubygem-rackto a version that resolves this vulnerability.Fixed in 2.2.6.1 - Upgrade
Upgrade
redhat/rubygem-rackto a version that resolves this vulnerability.Fixed in 3.0.4.1 - Upgrade
Upgrade
debian/ruby-rackto a version that resolves this vulnerability.Fixed in 2.2.4-3 - Upgrade
Upgrade
debian/ruby-rackto a version that resolves this vulnerability.Fixed in 2.2.22-0+deb12u1Fixed in 2.2.22-0+deb12u2Fixed in 3.1.20-0+deb13u1Fixed in 3.1.20-0+deb13u2Fixed in 3.2.7-1Fixed in 3.2.8-1 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Fixed in 2.0.9.2 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Fixed in 2.1.4.2 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Fixed in 2.2.6.1 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Fixed in 3.0.0.1 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Patch 2-0-Forbid-control-characters-in-attributes.patch - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Patch 2-1-Forbid-control-characters-in-attributes.patch - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Patch 2-2-Forbid-control-characters-in-attributes.patch - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Patch 3-0-Forbid-control-characters-in-attributes.patch
Event History
Frequently Asked Questions
What is the vulnerability ID for this vulnerability?
The vulnerability ID for this vulnerability is CVE-2022-44572.
What is the severity of CVE-2022-44572?
The severity of CVE-2022-44572 is high (7.5).
Which versions of Rack are affected by CVE-2022-44572?
Versions >= 2.0.0 of Rack are affected by CVE-2022-44572.
How can I fix CVE-2022-44572?
To fix CVE-2022-44572, update to one of the fixed versions: 2.0.9.2, 2.1.4.2, 2.2.6.1, or 3.0.0.1.
Where can I find more information about CVE-2022-44572?
You can find more information about CVE-2022-44572 on the following websites: [HackerOne](https://hackerone.com/reports/1639882), [Debian Security Advisory](https://www.debian.org/security/2023/dsa-5530), [GitHub Commit](https://github.com/rack/rack/commit/dc50f8e495f67eb933b1fc33ebee550908d945e6).