CVE-2022-4728: Graphite Web Cookie cross site scripting
A vulnerability has been found in Graphite Web and classified as problematic. This vulnerability affects unknown code of the component Cookie Handler. The manipulation leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. The name of the patch is 2f178f490e10efc03cd1d27c72f64ecab224eb23. It is recommended to apply a patch to fix this issue. VDB-216742 is the identifier assigned to this vulnerability.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 1.0.2+ - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.4-5ubuntu0.1 - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.8-1ubuntu0.22.04.1 - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 0.9.12+ - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 0.9.15+ - Upgrade
Upgrade
debian/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.8-2Fixed in 1.1.10-8Fixed in 1.2.1~pre2-1 - Upgrade
Upgrade
debian/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.8-1.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch 2f178f490e10efc03cd1d27c72f64ecab224eb23
Event History
Frequently Asked Questions
What is the severity of CVE-2022-4728?
CVE-2022-4728 is classified as a problematic vulnerability with potential for cross-site scripting attacks.
Which versions of Graphite Web are affected by CVE-2022-4728?
CVE-2022-4728 affects specific versions of Graphite Web including versions prior to 1.0.2+ and 1.1.4-5ubuntu0.1 among others.
How can I fix CVE-2022-4728?
To resolve CVE-2022-4728, upgrade Graphite Web to the latest advised version recommended for your distribution.
Can the CVE-2022-4728 vulnerability be exploited remotely?
Yes, CVE-2022-4728 allows for remote exploitation through cross-site scripting.
What component of Graphite Web does CVE-2022-4728 affect?
CVE-2022-4728 affects the Cookie Handler component of Graphite Web.